summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/thinkfinger')
-rw-r--r--sys-auth/thinkfinger/files/0.3-autoreconf.patch25
-rw-r--r--sys-auth/thinkfinger/files/0.3-slibtool.patch37
-rw-r--r--sys-auth/thinkfinger/thinkfinger-0.3-r3.ebuild9
3 files changed, 70 insertions, 1 deletions
diff --git a/sys-auth/thinkfinger/files/0.3-autoreconf.patch b/sys-auth/thinkfinger/files/0.3-autoreconf.patch
new file mode 100644
index 000000000000..f0b7a1c20232
--- /dev/null
+++ b/sys-auth/thinkfinger/files/0.3-autoreconf.patch
@@ -0,0 +1,25 @@
+From 922e00d123092da33f3237071236e28b0f120766 Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Sun, 28 Mar 2021 11:04:26 -0700
+Subject: [PATCH 1/2] build: Fix autoreconf.
+
+---
+ configure.in | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index 2bdd150..4b277b9 100644
+--- a/configure.in
++++ b/configure.in
+@@ -179,8 +179,6 @@ AM_CONDITIONAL(HAVE_OLD_PAM, test "x$HAVE_OLD_PAM" = "xyes")
+
+ # AC_CONFIG_FILES
+ AC_CONFIG_FILES([Makefile
+- README
+- INSTALL
+ docs/Makefile
+ docs/autodocs/Makefile
+ libthinkfinger/Makefile
+--
+2.26.3
+
diff --git a/sys-auth/thinkfinger/files/0.3-slibtool.patch b/sys-auth/thinkfinger/files/0.3-slibtool.patch
new file mode 100644
index 000000000000..2b56e9ce1c85
--- /dev/null
+++ b/sys-auth/thinkfinger/files/0.3-slibtool.patch
@@ -0,0 +1,37 @@
+From 477ef76901ae46d58202091060a763f9b4c4b57f Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Sun, 28 Mar 2021 11:08:43 -0700
+Subject: [PATCH 2/2] build: Fix creating the libpam_thinkfinger library.
+
+---
+ pam/Makefile.am | 13 ++++++-------
+ 1 file changed, 6 insertions(+), 7 deletions(-)
+
+diff --git a/pam/Makefile.am b/pam/Makefile.am
+index d3bfcab..38c3cab 100644
+--- a/pam/Makefile.am
++++ b/pam/Makefile.am
+@@ -1,14 +1,13 @@
+-pam_PROGRAMS = pam_thinkfinger.so
++pam_LTLIBRARIES = libpam_thinkfinger.la
+ pamdir = $(SECUREDIR)
+
+ INCLUDES = -I$(top_srcdir)/libthinkfinger
+
+ if HAVE_OLD_PAM
+-pam_thinkfinger_so_SOURCES = pam_thinkfinger-compat.c pam_thinkfinger-compat.h pam_thinkfinger-uinput.c pam_thinkfinger-uinput.h pam_thinkfinger.c
++libpam_thinkfinger_la_SOURCES = pam_thinkfinger-compat.c pam_thinkfinger-compat.h pam_thinkfinger-uinput.c pam_thinkfinger-uinput.h pam_thinkfinger.c
+ else
+-pam_thinkfinger_so_SOURCES = pam_thinkfinger-uinput.c pam_thinkfinger-uinput.h pam_thinkfinger.c
++libpam_thinkfinger_la_SOURCES = pam_thinkfinger-uinput.c pam_thinkfinger-uinput.h pam_thinkfinger.c
+ endif
+-pam_thinkfinger_so_LDFLAGS = -shared -Wl,-soname,pam_thinkfinger.so -Wl,--as-needed
+-pam_thinkfinger_so_CFLAGS = $(CFLAGS)
+-pam_thinkfinger_so_LDADD = $(top_builddir)/libthinkfinger/libthinkfinger.la $(PAM_LIBS) $(PTHREAD_LIBS)
+-
++libpam_thinkfinger_la_LDFLAGS = -shared -Wl,-soname,pam_thinkfinger.so -Wl,--as-needed
++libpam_thinkfinger_la_CFLAGS = $(CFLAGS)
++libpam_thinkfinger_la_LIBADD = $(top_builddir)/libthinkfinger/libthinkfinger.la $(PAM_LIBS) $(PTHREAD_LIBS)
+--
+2.26.3
+
diff --git a/sys-auth/thinkfinger/thinkfinger-0.3-r3.ebuild b/sys-auth/thinkfinger/thinkfinger-0.3-r3.ebuild
index 5148727daa45..d877ef488e97 100644
--- a/sys-auth/thinkfinger/thinkfinger-0.3-r3.ebuild
+++ b/sys-auth/thinkfinger/thinkfinger-0.3-r3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit linux-info pam
+inherit autotools linux-info pam
DESCRIPTION="Support for the UPEK/SGS Thomson fingerprint reader, common in Thinkpads"
HOMEPAGE="http://thinkfinger.sourceforge.net/"
@@ -28,6 +28,8 @@ PATCHES=(
"${FILESDIR}"/${PV}-send-sync-event.patch
"${FILESDIR}"/${PV}-tftoolgroup.patch
"${FILESDIR}"/${PV}-strip-strip.patch
+ "${FILESDIR}"/${PV}-autoreconf.patch
+ "${FILESDIR}"/${PV}-slibtool.patch
)
pkg_setup() {
@@ -38,6 +40,11 @@ pkg_setup() {
fi
}
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
econf \
--disable-static \