summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/ykpers/ykpers-1.18.0.ebuild')
-rw-r--r--sys-auth/ykpers/ykpers-1.18.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-auth/ykpers/ykpers-1.18.0.ebuild b/sys-auth/ykpers/ykpers-1.18.0.ebuild
new file mode 100644
index 000000000000..ab6fa079a788
--- /dev/null
+++ b/sys-auth/ykpers/ykpers-1.18.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools udev
+
+DESCRIPTION="Library and tool for personalization of Yubico's YubiKey"
+SRC_URI="https://github.com/Yubico/yubikey-personalization/archive/v${PV}.tar.gz"
+HOMEPAGE="https://github.com/Yubico/yubikey-personalization"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="BSD-2"
+IUSE="static-libs consolekit"
+
+RDEPEND="
+ >=sys-auth/libyubikey-1.6
+ virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ consolekit? ( sys-auth/consolekit[acl] )"
+
+S="${WORKDIR}/yubikey-personalization-${PV}"
+
+DOCS=( doc/. AUTHORS NEWS README )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ --localstatedir=/var \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use consolekit && udev_dorules *.rules
+}