summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/bmap-tools')
-rw-r--r--sys-block/bmap-tools/Manifest1
-rw-r--r--sys-block/bmap-tools/bmap-tools-3.6.ebuild54
-rw-r--r--sys-block/bmap-tools/metadata.xml11
3 files changed, 66 insertions, 0 deletions
diff --git a/sys-block/bmap-tools/Manifest b/sys-block/bmap-tools/Manifest
new file mode 100644
index 000000000000..e9012b8a510d
--- /dev/null
+++ b/sys-block/bmap-tools/Manifest
@@ -0,0 +1 @@
+DIST bmap-tools-3.6.tar.gz 97815 BLAKE2B 3c6728386d66283a4df0376c90d2eafc670bba835ca97ebe25ab12f5eb1f745dea9a55d8c287c815306b9d603b6d804f9711a19b2df23870355983ebce4c0a07 SHA512 a55fe88d8f136b39f2bb92690322ae65d66ae1ae0454050d74bd37a39d69dca6428ba05ff42d2faf8e83f8f8342d882caaf8bb45aa00c74bbd5e4b12289a406a
diff --git a/sys-block/bmap-tools/bmap-tools-3.6.ebuild b/sys-block/bmap-tools/bmap-tools-3.6.ebuild
new file mode 100644
index 000000000000..51a7426eaeea
--- /dev/null
+++ b/sys-block/bmap-tools/bmap-tools-3.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Flashing tool using block maps and sparse files"
+HOMEPAGE="https://github.com/intel/bmap-tools"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/intel/bmap-tools.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/intel/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+
+BDEPEND="${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}] )
+"
+
+RDEPEND="
+ app-arch/pigz
+ app-arch/lzop
+ app-arch/lz4
+ app-arch/pbzip2
+ app-arch/xz-utils
+ app-arch/bzip2
+ app-arch/gzip
+ app-arch/tar
+"
+
+DOCS=( "${S}/docs/README" )
+
+# tests are hanging using default below
+RESTRICT="!test? ( test )"
+
+distutils_enable_tests nose
+
+python_test() {
+ # remaining tests involve way too much file I/O
+ nosetests -sx --verbosity=3 --detailed-errors \
+ tests/test_bmap_helpers.py \
+ tests/test_compat.py || die "Tests fail with ${EPYTHON}"
+}
diff --git a/sys-block/bmap-tools/metadata.xml b/sys-block/bmap-tools/metadata.xml
new file mode 100644
index 000000000000..0c665a5d9e09
--- /dev/null
+++ b/sys-block/bmap-tools/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>embedded@gentoo.org</email>
+ <name>Embedded Gentoo</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">intel/bmap-tools</remote-id>
+ </upstream>
+</pkgmetadata>