summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/flashbench/files/flashbench-20120606-Makefile.patch')
-rw-r--r--sys-block/flashbench/files/flashbench-20120606-Makefile.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/sys-block/flashbench/files/flashbench-20120606-Makefile.patch b/sys-block/flashbench/files/flashbench-20120606-Makefile.patch
new file mode 100644
index 000000000000..0965a75c12c1
--- /dev/null
+++ b/sys-block/flashbench/files/flashbench-20120606-Makefile.patch
@@ -0,0 +1,23 @@
+diff --git a/Makefile b/Makefile
+index f83b220..ffe20fa 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+-CC := gcc
+-CFLAGS := -O2 -Wall -Wextra -Wno-missing-field-initializers -Wno-unused-parameter -g2
+-LDFLAGS := -lrt
++CC ?= gcc
++CFLAGS += -Wall -Wextra -Wno-missing-field-initializers -Wno-unused-parameter
++LIBS := -lrt
+
+ all: flashbench erase
+
+@@ -9,7 +9,7 @@ vm.o: vm.c vm.h dev.h
+ flashbench.o: flashbench.c vm.h dev.h
+
+ flashbench: flashbench.o dev.o vm.o
+- $(CC) -o $@ flashbench.o dev.o vm.o $(LDFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ flashbench.o dev.o vm.o $(LIBS)
+
+
+ erase: erase.o