summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/megamgr/megamgr-5.20-r2.ebuild')
-rw-r--r--sys-block/megamgr/megamgr-5.20-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-block/megamgr/megamgr-5.20-r2.ebuild b/sys-block/megamgr/megamgr-5.20-r2.ebuild
new file mode 100644
index 000000000000..450974bade25
--- /dev/null
+++ b/sys-block/megamgr/megamgr-5.20-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit multilib
+
+DESCRIPTION="LSI Logic MegaRAID Text User Interface management tool"
+HOMEPAGE="http://www.lsi.com"
+SRC_URI="http://www.lsi.com/downloads/Public/MegaRAID%20Common%20Files/ut_linux_${PN##mega}_${PV}.zip"
+
+LICENSE="LSI"
+SLOT="0"
+# This package can never enter stable, it can't be mirrored and upstream
+# can remove the distfiles from their mirror anytime.
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+RESTRICT="mirror fetch"
+
+S="${WORKDIR}"
+
+QA_PRESTRIPPED="/opt/bin/megamgr"
+
+pkg_nofetch() {
+ einfo "Upstream has implement a mandatory clickthrough EULA for distfile download"
+ einfo "Please visit $SRC_URI"
+ einfo "And place $A in ${DISTDIR}"
+}
+
+pkg_setup() {
+ use amd64 && { has_multilib_profile || die "needs multilib profile on amd64"; }
+}
+
+src_install() {
+ newdoc ut_linux_${PN##mega}_${PV}.txt ${PN}-release-${PV}.txt
+
+ exeinto /opt/bin
+ newexe megamgr.bin megamgr || die
+}