summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/nbd/nbd-3.15.1.ebuild')
-rw-r--r--sys-block/nbd/nbd-3.15.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-block/nbd/nbd-3.15.1.ebuild b/sys-block/nbd/nbd-3.15.1.ebuild
new file mode 100644
index 000000000000..f689da5d8c18
--- /dev/null
+++ b/sys-block/nbd/nbd-3.15.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Userland client/server for kernel network block device"
+HOMEPAGE="http://nbd.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nbd/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug zlib"
+
+# gnutls is an automagic dep.
+RDEPEND=">=dev-libs/glib-2.0
+ >=net-libs/gnutls-2.12.0
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --enable-lfs \
+ $(use_enable !debug syslog) \
+ $(use_enable debug) \
+ $(use_enable zlib gznbd)
+}