summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/open-iscsi')
-rw-r--r--sys-block/open-iscsi/Manifest1
-rw-r--r--sys-block/open-iscsi/files/open-iscsi-2.1.6-Makefiles.patch81
-rw-r--r--sys-block/open-iscsi/open-iscsi-2.1.6.ebuild141
3 files changed, 223 insertions, 0 deletions
diff --git a/sys-block/open-iscsi/Manifest b/sys-block/open-iscsi/Manifest
index 27e0fa000d2b..29d5b970a89c 100644
--- a/sys-block/open-iscsi/Manifest
+++ b/sys-block/open-iscsi/Manifest
@@ -1 +1,2 @@
DIST open-iscsi-2.1.4.tar.gz 621247 BLAKE2B 043a999b2f397a6c740d61654079d7ab966caee6cf6cfb244ddd70eae4f5201045b371ce5fbe244216a2a210a5379c92e8c3fbe62d33707cf05e7a4a20a13a91 SHA512 ae0663a964d86e6a4c19203598b859173c93ecce550f9bc9855ff735dd51a3c45822f2bc1cc99e6891c56ef1d16c42223803f07a961558fe6e38ead2164faef3
+DIST open-iscsi-2.1.6.tar.gz 623721 BLAKE2B c7c09e38fd10bd5c2a5e8ad8030cf2338de3382fe4acae0e3c1bf3cacb6e244e411b7556403e0c43fd03035836f46cc4836683188e2f159cd7fc066aef78a868 SHA512 4a32a76c1c32d7d1a01fe3a0f88ce9616a54323ec043757be73051eb41ebae8de90ce057acce72fb6fe07aa47e814c9bc6ee88b13fa7d7769ca10c5175974f1d
diff --git a/sys-block/open-iscsi/files/open-iscsi-2.1.6-Makefiles.patch b/sys-block/open-iscsi/files/open-iscsi-2.1.6-Makefiles.patch
new file mode 100644
index 000000000000..a25acc0c85db
--- /dev/null
+++ b/sys-block/open-iscsi/files/open-iscsi-2.1.6-Makefiles.patch
@@ -0,0 +1,81 @@
+https://github.com/open-iscsi/open-iscsi/pull/333
+
+It's not the full series from that PR yet because
+our previous patch handles some of it (the most important bits)
+and some layout changed upstream pre-next release.
+
+From 96667e0e06a65c94fd875db048776aad29eea829 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 3 Apr 2022 03:22:32 +0100
+Subject: [PATCH] iscsiuio: don't clobber LDFLAGS in configure.ac
+
+The systemd check currently clobbers LDFLAGS from the environment
+rather than appending to it.
+
+But we actually want LIBS here anyway, rather than LDFLAGS.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/iscsiuio/configure.ac
++++ b/iscsiuio/configure.ac
+@@ -72,7 +72,7 @@ AC_ARG_WITH([systemd],
+ *) AC_MSG_ERROR([bad value $withval for --with-systemd]) ;;
+ esac],[with_libsystemd=auto])
+ AS_IF([test "$with_libsystemd" != no],[
+- PKG_CHECK_MODULES([LIBSYSTEMD],[libsystemd],[LDFLAGS=$LIBSYSTEMD_LIBS],[
++ PKG_CHECK_MODULES([LIBSYSTEMD],[libsystemd],[LIBS="${LIBS} $LIBSYSTEMD_LIBS"],[
+ if test "$with_libsystemd" = yes; then
+ AC_MSG_ERROR([could not find libsystemd using pkg-config])
+ else
+From 9fbd6009cd917f1152a367fa7e5ae3993133c1e4 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 3 Apr 2022 03:23:28 +0100
+Subject: [PATCH] iscsiuio: respect LDFLAGS fully
+
+Use LIBS rather than LDFLAGS which ensures automake gets the ordering
+right (some LDFLAGS values won't work correctly if not placed exactly before
+libraries).
+
+This should functionally work the same as before, just improve compatibility
+with bits like -Wl,--as-needed.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/iscsiuio/src/unix/Makefile.am
++++ b/iscsiuio/src/unix/Makefile.am
+@@ -27,13 +27,14 @@ iscsiuio_CFLAGS = $(AM_CFLAGS) \
+ $(LIBNL_CFLAGS) \
+ -DBYTE_ORDER=@ENDIAN@
+
+-iscsiuio_LDFLAGS= $(AM_LDADD) \
++iscsiuio_LIBS = $(AM_LIBS) \
+ -ldl \
+ -rdynamic \
+ $(LIBNL_LIBS) \
+ -lpthread
+
+-iscsiuio_LDADD = ${top_srcdir}/src/uip/lib_iscsi_uip.a \
++iscsiuio_LDADD = $(AM_LDADD) \
++ ${top_srcdir}/src/uip/lib_iscsi_uip.a \
+ ${top_srcdir}/src/apps/dhcpc/lib_apps_dhcpc.a\
+ ${top_srcdir}/src/apps/brcm-iscsi/lib_apps_brcm_iscsi.a \
+ ${top_srcdir}/src/unix/libs/lib_iscsiuio_hw_cnic.a
+From 980b1d36e1f5f38c6b33fe3b68a2cb89e4a77b90 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 3 Apr 2022 03:34:48 +0100
+Subject: [PATCH] libopeniscsiusr: fix version in installed pkgconfig (.pc)
+ file
+
+Looks like a typo from libnvme. Previously, the installed
+.pc file had a blank Version field.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/libopeniscsiusr/Makefile
++++ b/libopeniscsiusr/Makefile
+@@ -89,7 +89,7 @@ install: $(LIBS) $(LIBS_MAJOR)
+ ln -sf $(LIBS) $(DESTDIR)/$(LIB_DIR)/$(LIBS_MAJOR)
+ $(INSTALL) $(HEADERS) $(DESTDIR)$(INCLUDE_DIR)/
+ $(INSTALL) -m 644 -D $(PKGFILE).in $(DESTDIR)$(PKGCONF_DIR)/$(PKGFILE)
+- perl -i -pe 's|__VERSION__|$(LIBNVME_VERSION)|g' \
++ perl -i -pe 's|__VERSION__|$(LIBISCSI_USR_VERSION)|g' \
+ $(DESTDIR)$(PKGCONF_DIR)/$(PKGFILE)
+ perl -i -pe 's|__LIB_DIR__|$(LIB_DIR)|g' \
+ $(DESTDIR)$(PKGCONF_DIR)/$(PKGFILE)
diff --git a/sys-block/open-iscsi/open-iscsi-2.1.6.ebuild b/sys-block/open-iscsi/open-iscsi-2.1.6.ebuild
new file mode 100644
index 000000000000..bcda02c039ab
--- /dev/null
+++ b/sys-block/open-iscsi/open-iscsi-2.1.6.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools linux-info flag-o-matic toolchain-funcs systemd
+
+DESCRIPTION="A performant, transport independent, multi-platform implementation of RFC3720"
+HOMEPAGE="https://www.open-iscsi.com/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/0.2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug infiniband +tcp rdma systemd"
+REQUIRED_USE="infiniband? ( rdma ) || ( rdma tcp )"
+
+DEPEND="
+ sys-apps/kmod
+ sys-block/open-isns:=
+ sys-kernel/linux-headers
+ infiniband? ( sys-cluster/rdma-core )
+ dev-libs/openssl:0=
+ systemd? ( sys-apps/systemd )
+"
+RDEPEND="${DEPEND}
+ sys-fs/lsscsi
+ sys-apps/util-linux"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1.1-Makefiles.patch
+ "${FILESDIR}"/open-iscsi-2.1.6-Makefiles.patch
+)
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ if kernel_is -lt 2 6 16; then
+ die "Sorry, your kernel must be 2.6.16-rc5 or newer!"
+ fi
+
+ # Needs to be done, as iscsid currently only starts, when having the iSCSI
+ # support loaded as module. Kernel builtin options don't work. See this for
+ # more information:
+ # https://groups.google.com/group/open-iscsi/browse_thread/thread/cc10498655b40507/fd6a4ba0c8e91966
+ # If there's a new release, check whether this is still valid!
+ TCP_MODULES="SCSI_ISCSI_ATTRS ISCSI_TCP"
+ RDMA_MODULES="INFINIBAND_ISER"
+ INFINIBAND_MODULES="INFINIBAND_IPOIB INIBAND_USER_MAD INFINIBAND_USER_ACCESS"
+ CONFIG_CHECK_MODULES="tcp? ( ${TCP_MODULES} ) rdma? ( ${RDMA_MODULES} ) infiniband? ( ${INFINIBAND_MODULES} )"
+ if linux_config_exists; then
+ if use tcp; then
+ for module in ${TCP_MODULES}; do
+ linux_chkconfig_module ${module} || ewarn "${module} needs to be built as module (builtin doesn't work)"
+ done
+ fi
+ if use infiniband; then
+ for module in ${INFINIBAND_MODULES}; do
+ linux_chkconfig_module ${module} || ewarn "${module} needs to be built as module (builtin doesn't work)"
+ done
+ fi
+ if use rdma; then
+ for module in ${RDMA_MODULES}; do
+ linux_chkconfig_module ${module} || ewarn "${module} needs to be built as module (builtin doesn't work)"$
+ done
+ fi
+ fi
+}
+
+src_prepare() {
+ sed -e 's:^\(iscsid.startup\)\s*=.*:\1 = /usr/sbin/iscsid:' \
+ -i etc/iscsid.conf || die
+ sed -e '/[^usr]\/sbin/s@\(/sbin/\)@/usr\1@' \
+ -i etc/systemd/iscsi* || die
+ default
+
+ pushd iscsiuio >/dev/null || die
+ eautoreconf
+ popd >/dev/null || die
+}
+
+src_configure() {
+ use debug && append-cppflags -DDEBUG_TCP -DDEBUG_SCSI
+
+ append-lfs-flags
+}
+
+src_compile() {
+ # Stuffing CPPFLAGS into CFLAGS isn't entirely correct, but the build
+ # is messed up already here, so it's not making it that much worse.
+ KSRC="${KV_DIR}" CFLAGS="" \
+ emake \
+ OPTFLAGS="${CFLAGS} ${CPPFLAGS} $(usex systemd '' -DNO_SYSTEMD)" \
+ AR="$(tc-getAR)" CC="$(tc-getCC)" \
+ $(usex systemd '' NO_SYSTEMD=1) \
+ user
+}
+
+src_install() {
+ emake DESTDIR="${ED}" sbindir="/usr/sbin" SED="${EPREFIX}/bin/sed" install
+
+ # Upstream make is not deterministic, per bug #601514
+ rm -f "${ED}"/etc/initiatorname.iscsi
+
+ dodoc README THANKS
+
+ docinto test/
+ dodoc $(find test -maxdepth 1 -type f ! -name ".*")
+
+ insinto /etc/iscsi
+ newins "${FILESDIR}"/initiatorname.iscsi initiatorname.iscsi.example
+
+ newconfd "${FILESDIR}"/iscsid-conf.d iscsid
+ newinitd "${FILESDIR}"/iscsid-init.d iscsid
+
+ local unit
+ local units=(
+ iscsi{,-init}.service
+ iscsid.{service,socket}
+ iscsiuio.{service,socket}
+ )
+ for unit in ${units[@]} ; do
+ systemd_dounit etc/systemd/${unit}
+ done
+
+ keepdir /var/db/iscsi
+ fperms 700 /var/db/iscsi
+ fperms 600 /etc/iscsi/iscsid.conf
+}
+
+pkg_postinst() {
+ in='/etc/iscsi/initiatorname.iscsi'
+ if [[ ! -f "${EROOT}${in}" ]] && [[ -f "${EROOT}${in}.example" ]] ; then
+ {
+ cat "${EROOT}${in}.example"
+ echo "# InitiatorName generated by ${CATEGORY}/${PF} at $(date -uR)"
+ echo "InitiatorName=$(${ROOT}/usr/sbin/iscsi-iname)"
+ } >> "${EROOT}${in}.tmp" && mv -f "${EROOT}${in}.tmp" "${EROOT}${in}"
+ fi
+}