summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/parted')
-rw-r--r--sys-block/parted/files/parted-3.6-underlinked-util-linux.patch35
-rw-r--r--sys-block/parted/parted-3.6-r2.ebuild (renamed from sys-block/parted/parted-3.6-r1.ebuild)2
2 files changed, 36 insertions, 1 deletions
diff --git a/sys-block/parted/files/parted-3.6-underlinked-util-linux.patch b/sys-block/parted/files/parted-3.6-underlinked-util-linux.patch
index 6e02f4aac8d8..1b23c27398fb 100644
--- a/sys-block/parted/files/parted-3.6-underlinked-util-linux.patch
+++ b/sys-block/parted/files/parted-3.6-underlinked-util-linux.patch
@@ -1,5 +1,6 @@
https://bugs.gentoo.org/910487
https://git.savannah.gnu.org/cgit/parted.git/commit/?id=d22c2d01f62139e0d386d90584cac0705857a571
+https://git.savannah.gnu.org/cgit/parted.git/commit/?id=60b3300ed6d3ba2e7af4ddce55bd873b232d12ff
From d22c2d01f62139e0d386d90584cac0705857a571 Mon Sep 17 00:00:00 2001
From: Yegor Yefremov <yegorslists@googlemail.com>
@@ -24,3 +25,37 @@ Signed-off-by: Brian C. Lane <bcl@redhat.com>
if test $ENABLE_DEVICE_MAPPER = yes; then
--
cgit v1.1
+
+From 60b3300ed6d3ba2e7af4ddce55bd873b232d12ff Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 12 Jun 2023 10:55:19 -0700
+Subject: bug#64034: [PATCH] libparted: link libparted-fs-resize.so to libuuid
+
+uuid_generate() is used in this library
+Hence, add UUID_LIBS to libparted_fs_resize_la_LIBADD to avoid
+
+"ld.lld: error: undefined reference due to --no-allow-shlib-undefined: uuid_generate"
+
+This is uncovered by lld linker linking fatresize package
+due to this linker defaulting to --no-allow-shlib-undefined.
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Signed-off-by: Brian C. Lane <bcl@redhat.com>
+---
+ libparted/fs/Makefile.am | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/libparted/fs/Makefile.am b/libparted/fs/Makefile.am
+index 41a60d9..7fa8d14 100644
+--- a/libparted/fs/Makefile.am
++++ b/libparted/fs/Makefile.am
+@@ -75,6 +75,7 @@ libparted_fs_resize_la_LDFLAGS = \
+ EXTRA_DIST += fsresize.sym
+ libparted_fs_resize_la_DEPENDENCIES = $(sym_file)
+
++libparted_fs_resize_la_LIBADD = $(UUID_LIBS)
+ libparted_fs_resize_la_SOURCES = \
+ r/filesys.c \
+ r/fat/bootsector.c \
+--
+cgit v1.1
diff --git a/sys-block/parted/parted-3.6-r1.ebuild b/sys-block/parted/parted-3.6-r2.ebuild
index ea3667cc4060..38a0f57020cb 100644
--- a/sys-block/parted/parted-3.6-r1.ebuild
+++ b/sys-block/parted/parted-3.6-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7