summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/raid-check/raid-check-20140719-r1.ebuild')
-rw-r--r--sys-block/raid-check/raid-check-20140719-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-block/raid-check/raid-check-20140719-r1.ebuild b/sys-block/raid-check/raid-check-20140719-r1.ebuild
new file mode 100644
index 000000000000..9815affb01ed
--- /dev/null
+++ b/sys-block/raid-check/raid-check-20140719-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Script to do \"scrubbing\" on software RAID systems"
+HOMEPAGE="https://github.com/fukawi2/raid-check"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-path.patch
+)
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+}
+
+src_compile() { :; }
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ emake DESTDIR="${D}" D_BIN=/usr/sbin install
+}