summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/sas3flash')
-rw-r--r--sys-block/sas3flash/Manifest1
-rw-r--r--sys-block/sas3flash/sas3flash-15-r1.ebuild86
2 files changed, 0 insertions, 87 deletions
diff --git a/sys-block/sas3flash/Manifest b/sys-block/sas3flash/Manifest
index 5c67d24162fd..25630b44cf81 100644
--- a/sys-block/sas3flash/Manifest
+++ b/sys-block/sas3flash/Manifest
@@ -1,5 +1,4 @@
DIST Installer_P16_for_Linux.zip 931509 BLAKE2B 059ce415dde9c872bd5e235bd3168a01bd966fc7433b297875849d563bf57d9207b5d4ce253bd9ac40072353a77ab403ecf110c21758edc5a1a832d7a8af6066 SHA512 fde7967e45f13c81b40b53f9d8893de8bf8b16b8c008b197ddfdcdc0338675c9926b53fc48f38087ca35738de3b8da662d22bdd620648eafb0c8889b48e94431
DIST Installer_P16_for_Solaris.zip 450562 BLAKE2B 6aa3ce50128a719fb36d8c9a28f87dc43a4c90f261b373dbe0455f1803dea4212b85efc2c5961a7da9254c21938ff189b893eec44a8e959589df59073517296a SHA512 6a73b142ba50d8c3b6427d96153367e96498787a48bef2ea784fba8567ab9a32554fc8560c3ea798b7f7c04af7a8115d778532087aeca6d7b64fbf4a6be5d649
DIST Installer_P16_for_UEFI.zip 360466 BLAKE2B 8c98387033bc3979a62c1e29e78678563d32ac9e6a90359160fe64694b765cc083ec1c4e3d816ee9fbcc9390fc195078e4b18976d24c3ed79d93baf69c5bff5d SHA512 f670690df3d024dc968325354650c4279ff9823c6e9846cf37b7a7e3ba0ed77e1a94c8e358c691a41dfd1d438215448cb4fb1df246e5a1e6fa72bbfa3e5ee710
-DIST SAS3FLASH_P15.zip 5284358 BLAKE2B 8602db381d7ce7fbca7b55c0f7a9ec4868153264624a5c64d7602a5b094e16c274df22d4e4e8c2f3dca08ff5b550b5aa8dc72d25fef74a65b8eb24f4dd213934 SHA512 19fe0b313a210c02017234e0784dffde83eb9a9bcca1c98221bc5fd56e0cc196e53f857c5c0d0db37176f59d70cb85aaef3983b1f900a9f2031b9fcd2cfaf9eb
DIST sas3Flash_quickRefGuide_rev1-0.pdf 301289 BLAKE2B c52a00b7dd6abd14d2a476ed2fca9d56d59555c7f92b802cd37f9876c17d83a9919df6e9c64697eefd2195bec01a1eed14884c3f7daa82195f276032d37a146b SHA512 88129695ac971a28d472f3cea3af8a99fcff508b29b2c7c74994b6854515710239a6bbff766fc4fd31af8726784a3799b2a63a9dd8241e97b34d4e05638e088b
diff --git a/sys-block/sas3flash/sas3flash-15-r1.ebuild b/sys-block/sas3flash/sas3flash-15-r1.ebuild
deleted file mode 100644
index 6ea3f68cb1f4..000000000000
--- a/sys-block/sas3flash/sas3flash-15-r1.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit mount-boot
-
-DESCRIPTION="Flash utility for LSI MPT-SAS3 controller"
-HOMEPAGE="https://www.broadcom.com/products/storage/host-bus-adapters/sas-9300-8e#downloads"
-
-LICENSE="LSI"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86 ~x64-solaris"
-IUSE="doc efi"
-
-RESTRICT="strip fetch mirror"
-BDEPEND="app-arch/unzip"
-QA_PREBUILT="opt/lsi/sas3flash boot/efi/sas3flash.efi"
-
-MY_PN=SAS3FLASH
-MY_P="${MY_PN}_P${PV}"
-
-DISTFILE_BIN=${MY_P}.zip
-DISTFILE_DOC=sas3Flash_quickRefGuide_rev1-0.pdf
-
-SRC_URI_BASE='https://docs.broadcom.com/docs-and-downloads'
-SRC_URI="
- ${SRC_URI_BASE}/host-bus-adapters/host-bus-adapters-common-files/sas_sata_12g_p${PV}/${DISTFILE_BIN}
- doc? ( "${SRC_URI_BASE}/oracle/files/${DISTFILE_DOC}" )"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_nofetch() {
- elog "Broadcom has a mandatory click-through license on their binaries."
- elog "Please visit ${HOMEPAGE} and download ${DISTFILE_BIN} from the Mangement Software section."
- elog "After downloading, move ${DISTFILE_BIN} into your DISTDIR directory."
- if use doc; then
- elog "Please also download 'SAS3Flash Utility Quick Reference Guide' (${DISTFILE_DOC}) "
- elog "and also place it into your DISTDIR directory."
- fi
- einfo "${SRC_URI}"
-}
-
-supportedcards() {
- elog "This binary supports should support ALL cards, including, but not"
- elog "limited to the following series:"
- elog ""
- elog "LSI SAS 3004"
- elog "LSI SAS 3008"
- elog "LSI SAS 3108"
- elog "LSI SAS 3116"
- elog "LSI SAS 3208"
- elog "LSI SAS 3308"
-}
-
-src_install() {
- # The second number is some sort of internal revision that is inconsistent between releases.
- local DOCS=( FLASH_MPT_GEN3_Phase"${PV}".0-*.pdf "README_SAS3FLASH_P${PV}.txt" )
-
- if use doc; then
- DOCS+=( "${DISTDIR}/${DISTFILE_DOC}" )
- fi
-
- default
-
- exeinto /opt/lsi/
- if use amd64; then
- doexe sas3flash_rel/sas3flash/sas3flash_linux_x64_rel/sas3flash
- elif use x86; then
- doexe sas3flash_rel/sas3flash/sas3flash_linux_x86_rel/sas3flash
- elif use arm64; then
- doexe sas3flash_rel/sas3flash/sas3flash_linux_arm_rel/sas3flash
- elif use ppc64; then
- doexe sas3flash_rel/sas3flash/sas3flash_linux_ppc64_rel/sas3flash
- elif use x64-solaris; then
- doexe sas3flash_rel/sas3flash/sas3flash_solaris_x86_rel/sas3flash
- fi
-
- if use efi; then
- exeinto /boot/efi/
- if use amd64; then
- doexe sas3flash_rel/sas3flash/sas3flash_udk_uefi_x64_rel/sas3flash.efi
- elif use arm64; then
- doexe sas3flash_rel/sas3flash/sas3flash_udk_uefi_arm_rel/sas3flash.efi
- fi
- fi
-}