summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/targetcli-fb')
-rw-r--r--sys-block/targetcli-fb/Manifest1
-rw-r--r--sys-block/targetcli-fb/targetcli-fb-2.1.54.ebuild4
-rw-r--r--sys-block/targetcli-fb/targetcli-fb-2.1.58.ebuild30
3 files changed, 33 insertions, 2 deletions
diff --git a/sys-block/targetcli-fb/Manifest b/sys-block/targetcli-fb/Manifest
index c5634ee261c3..f7f403fb8396 100644
--- a/sys-block/targetcli-fb/Manifest
+++ b/sys-block/targetcli-fb/Manifest
@@ -1 +1,2 @@
DIST targetcli-fb-2.1.54.tar.gz 39565 BLAKE2B 6eeb7da39fb047f9123fe12ea92a41d8e6fbd6728fdde8e1315e0c0224ad8abfa29df798680949d89cad6ff5afcac8112bbcc63b019f6245eff12089ea7b64d3 SHA512 dd008b8c47acc095078454c94b0c6f19ba88f86ddf1b5335eb050abf61d89ce1ffb7411ff3a174de60ed9759e6337206253aa9b2def6497b85c884a0a111308d
+DIST targetcli-fb-2.1.58.tar.gz 39546 BLAKE2B bfbe8435e49874803550225aa6d0b002382e5858c151503266a63a3368ffe19b3b076f41b4d091a4c7eaa3c6d70d0df2a0f07035b8f462fedeea20e00f915805 SHA512 1ef1dda1d8df8e98ba8a5882368477dfb5a0aa880c535dbe526e221dc5be32c49eaadda6c54f60b045288277d6d80dc6b47283fc656144f8ab5cde570d7e6343
diff --git a/sys-block/targetcli-fb/targetcli-fb-2.1.54.ebuild b/sys-block/targetcli-fb/targetcli-fb-2.1.54.ebuild
index 3f6d5ded9f8e..5d09776d5154 100644
--- a/sys-block/targetcli-fb/targetcli-fb-2.1.54.ebuild
+++ b/sys-block/targetcli-fb/targetcli-fb-2.1.54.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 systemd
DESCRIPTION="Command shell for managing Linux LIO kernel target"
diff --git a/sys-block/targetcli-fb/targetcli-fb-2.1.58.ebuild b/sys-block/targetcli-fb/targetcli-fb-2.1.58.ebuild
new file mode 100644
index 000000000000..4a1da00297f2
--- /dev/null
+++ b/sys-block/targetcli-fb/targetcli-fb-2.1.58.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 systemd
+
+DESCRIPTION="Command shell for managing Linux LIO kernel target"
+HOMEPAGE="https://github.com/open-iscsi/targetcli-fb"
+SRC_URI="https://github.com/open-iscsi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="dev-python/configshell-fb[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=dev-python/rtslib-fb-2.1.73[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ sys-apps/dbus"
+
+src_install() {
+ distutils-r1_src_install
+
+ keepdir /etc/target /etc/target/backup
+ doman targetcli.8
+ systemd_dounit systemd/targetclid.{service,socket}
+}