summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/gparted/Manifest1
-rw-r--r--sys-block/gparted/files/gparted-1.3.1-musl-nullptr.patch51
-rw-r--r--sys-block/gparted/files/gparted-1.4.0-musl-basename.patch53
-rw-r--r--sys-block/gparted/gparted-1.4.0-r1.ebuild95
4 files changed, 0 insertions, 200 deletions
diff --git a/sys-block/gparted/Manifest b/sys-block/gparted/Manifest
index 9cb29a891c24..1fe416d375a5 100644
--- a/sys-block/gparted/Manifest
+++ b/sys-block/gparted/Manifest
@@ -1,2 +1 @@
-DIST gparted-1.4.0.tar.gz 4308426 BLAKE2B 834782196e7cfe5c5553200743cbbaf700e59ef01076919d16138e736ebbbb16185ec68cd27546f1ff851ff742c51fc170a0f6596e9b014684b8be1d29acfea9 SHA512 20f94622fc1a2727f1fc9bb39ea9f04f14af06b0ff7e47c2149730d5eb339089b0d3c21cd3c9ce6f971e955a9f6ab89cc32fd5b7545a5e340b451297d87e8f39
DIST gparted-1.5.0.tar.gz 5416965 BLAKE2B 034fcbfde4b74f99769f5bff27ec7a84f7f6cf8e37d944aa7bce61d0421f02711d77bc695667ea34523b066c6f925437e24d34c5b172fe56be5ce23f99283f53 SHA512 af32358bc470d30c38cdf688e8f940548c7361808fbc7712dc79ef6d196e3bfbf9c9e0ee499729e78d4b782ed1f52ea1f55c983e9afe8fc3fea765078ffbddad
diff --git a/sys-block/gparted/files/gparted-1.3.1-musl-nullptr.patch b/sys-block/gparted/files/gparted-1.3.1-musl-nullptr.patch
deleted file mode 100644
index 2a4f648db609..000000000000
--- a/sys-block/gparted/files/gparted-1.3.1-musl-nullptr.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-https://gitlab.gnome.org/GNOME/gparted/-/commit/3d4b1c1e7b33f229efd254fb0cc06660af627ea0
-https://bugs.gentoo.org/838466
-
-From: Dominika Liberda <ja@sdomi.pl>
-Date: Sun, 10 Apr 2022 21:09:56 +0200
-Subject: [PATCH] Fix NULL == 0 assumption in call to ped_partition_flag_next()
- (!100)
-
-GParted fails to build on Alpine Linux Edge (development tree for the
-next release) like this:
-
- GParted_Core.cc: In constructor 'GParted::GParted_Core::GParted_Core()':
- GParted_Core.cc:75:64: error: invalid 'static_cast' from type 'std::nullptr_t' to type 'PedPartitionFlag'
- 75 | for ( PedPartitionFlag flag = ped_partition_flag_next( static_cast<PedPartitionFlag>( NULL ) ) ;
- | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-
-The code is failing to compile now because musl libc 1.2.3 has became
-more C++11 strict [1][2] by defining NULL [3] as nullptr [4] rather than
-as 0. The parameter to ped_partition_flag_next() [5] should always have
-been numeral 0 cast to an enumeration and never the NULL pointer.
-
-Fixes this commit [6] from 2004-12-27 which changed the parameter from 0
-to NULL.
-
-[1] define NULL as nullptr when used in C++11 or later
- https://git.musl-libc.org/cgit/musl/commit?id=98e688a9da5e7b2925dda17a2d6820dddf1fb28
-[2] NULL vs nullptr (Why was it replaced?) [duplicate]
- https://stackoverflow.com/questions/20509734/null-vs-nullptr-why-was-it-replaced
-[3] C++ reference, NULL
- https://en.cppreference.com/w/cpp/types/NULL
-[4] C++ reference, nullptr
- https://en.cppreference.com/w/cpp/language/nullptr
-[5] libparted Documentation, ped_partition_flag_next()
- https://www.gnu.org/software/parted/api/group__PedPartition.html#g0ce9ce4247b320011bc8e9d957c8cdbb
-[6] Added cylsize to Device and made Operation contain a Device instead
- commit 174f0cff77c5799a713954a22b2c54306d03036c
-
-Closes !100 - Fix NULL == 0 assumption in call to
- ped_partition_flag_next()
---- a/src/GParted_Core.cc
-+++ b/src/GParted_Core.cc
-@@ -72,7 +72,7 @@ GParted_Core::GParted_Core()
- ped_exception_set_handler( ped_exception_handler ) ;
-
- //get valid flags ...
-- for ( PedPartitionFlag flag = ped_partition_flag_next( static_cast<PedPartitionFlag>( NULL ) ) ;
-+ for ( PedPartitionFlag flag = ped_partition_flag_next( static_cast<PedPartitionFlag>( 0 ) ) ;
- flag ;
- flag = ped_partition_flag_next( flag ) )
- flags .push_back( flag ) ;
-GitLab
diff --git a/sys-block/gparted/files/gparted-1.4.0-musl-basename.patch b/sys-block/gparted/files/gparted-1.4.0-musl-basename.patch
deleted file mode 100644
index eeba8867ed42..000000000000
--- a/sys-block/gparted/files/gparted-1.4.0-musl-basename.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-https://gitlab.gnome.org/GNOME/gparted/-/merge_requests/99.patch
-https://bugs.gentoo.org/837794
-
-From 45c00927b72319f00855c7feaf4dcf109b3e4414 Mon Sep 17 00:00:00 2001
-From: Markus Volk <f_l_k@t-online.de>
-Date: Fri, 8 Apr 2022 08:58:46 +0000
-Subject: [PATCH] Use POSIX basename() in BCache_Info.cc (!99)
-
-Musl libc [1][2] doesn't implement the GNU variant of basename() [3][4],
-obtained via #include <string.h>. Therefore GParted fails to build on
-such distributions:
-
- fdebug-prefix-map=TOPDIR/build/tmp/work/cortexa57-yoe-linux-musl/gparted/1.4.0-r0/recipe-sysroot-native=-fvisibility-inlines-hidden -c -o ../../gparted-1.4.0/src/BCache_Info.cc:52:33:
-
- error: use of undeclared identifier 'basename'; did you mean 'g_basename'?
- return "/dev/" + Glib::ustring(basename(buf));
- ^~~~~~~~
- g_basename
-
-Fix by using the POSIX implementation of basename() [5] instead,
-obtained via #include <libgen.h>, which musl libc does implement [6].
-Note that the POSIX implementation of basename() is allowed to modify
-the string passed to it. This is okay because
-BCache_Info::get_bcache_device() is using a modifiable local character
-buffer.
-
-[1] musl libc
- https://musl.libc.org/
-[2] Projects using musl
- https://wiki.musl-libc.org/projects-using-musl.html
-[3] The GNU C Library, 5.10 Finding Tokens in a String
- https://www.gnu.org/software/libc/manual/html_node/Finding-Tokens-in-a-String.html
-[4] basename(3) - Linux manual page
- https://man7.org/linux/man-pages/man3/basename.3.html
-[5] POSIX basename()
- https://pubs.opengroup.org/onlinepubs/009695399/functions/basename.html
-[6] musl source, basename.c
- http://git.musl-libc.org/cgit/musl/tree/src/misc/basename.c
-
-Closes !99 - Fix undeclared identifier 'basename' build failure with
- musl libc
---- a/src/BCache_Info.cc
-+++ b/src/BCache_Info.cc
-@@ -17,7 +17,7 @@
-
- #include "BCache_Info.h"
-
--#include <string.h> // GNU version of basename()
-+#include <libgen.h> // POSIX version of basename()
- #include <unistd.h>
- #include <glibmm/ustring.h>
- #include <glibmm/fileutils.h>
-GitLab
diff --git a/sys-block/gparted/gparted-1.4.0-r1.ebuild b/sys-block/gparted/gparted-1.4.0-r1.ebuild
deleted file mode 100644
index 4afb483a97e0..000000000000
--- a/sys-block/gparted/gparted-1.4.0-r1.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit gnome2 optfeature virtualx
-
-DESCRIPTION="Partition editor for graphically managing your disk partitions"
-HOMEPAGE="https://gparted.org/ https://gitlab.gnome.org/GNOME/gparted/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2+ FDL-1.2+"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ppc ppc64 ~riscv x86"
-IUSE="kde policykit wayland"
-
-DEPEND="
- !policykit? (
- kde? ( >=kde-plasma/kde-cli-tools-5.8.6-r1[kdesu] ) )
- policykit? ( >=sys-auth/polkit-0.102 )
- >=dev-cpp/glibmm-2.56.1:2
- >=dev-cpp/gtkmm-3.24:3.0
- >=dev-libs/glib-2.58.3-r1:2
- >=sys-block/parted-3.2:=
- >=dev-libs/libsigc++-2.10.1:2
-"
-RDEPEND="${DEPEND}
- >=sys-apps/util-linux-2.33.2
- wayland? ( x11-apps/xhost )
-"
-BDEPEND="
- app-text/docbook-xml-dtd:4.1.2
- >=dev-util/intltool-0.51.0-r2
- dev-util/itstool
- sys-devel/gettext
- virtual/pkgconfig
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.3.1-musl-nullptr.patch
- "${FILESDIR}"/${PN}-1.4.0-musl-basename.patch
-)
-
-src_configure() {
- gnome2_src_configure \
- --enable-doc \
- --enable-online-resize \
- $(use_enable wayland xhost-root) \
- GKSUPROG=kdesu \
- ac_cv_prog_have_scrollkeeper_update=no
-}
-
-src_install() {
- gnome2_src_install
-
- local _ddir="${D}"/usr/share/applications
- local _bdir="${D}"/usr/bin
-
- if ! use policykit; then
- if use kde; then
- cp "${_ddir}"/gparted{,-kde}.desktop || die
- cp "${_bdir}"/gparted{,-kde} || die
- sed -i -e '/Exec/ s:gparted:gparted-kde:' "${_ddir}"/gparted-kde.desktop || die
- echo 'OnlyShowIn=KDE;' >> "${_ddir}"/gparted-kde.desktop || die
- fi
- else
- sed -i -e 's:kdesu::' "${_bdir}"/gparted || die
- fi
-
- mv "${ED}"/usr/share/{appdata,metainfo}
-}
-
-src_test() {
- virtx emake check
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
-
- optfeature_header
- optfeature "BTRFS support" sys-fs/btrfs-progs
- optfeature "DMRAID support" sys-fs/dmraid sys-fs/multipath-tools
- optfeature "Encrypted device / LUKS support" sys-fs/cryptsetup
- optfeature "exFAT support" sys-fs/exfatprogs
- optfeature "EXT2/EXT3/EXT4 support" sys-fs/e2fsprogs
- optfeature "F2FS support" sys-fs/f2fs-tools
- optfeature "FAT support" sys-fs/dosfstools sys-fs/mtools
- optfeature "HFS support" sys-fs/diskdev_cmds sys-fs/hfsutils virtual/udev
- optfeature "JFS support" sys-fs/jfsutils
- optfeature "MDADM support" sys-fs/mdadm
- optfeature "NTFS support" sys-fs/ntfs3g[ntfsprogs]
- optfeature "Reiser4 support" sys-fs/reiser4progs
- optfeature "ReiserFS support" sys-fs/reiserfsprogs
- optfeature "UDF support" sys-fs/udftools
- optfeature "XFS support" sys-fs/xfsprogs sys-fs/xfsdump
-}