summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/parted/parted-3.3-r1.ebuild35
1 files changed, 18 insertions, 17 deletions
diff --git a/sys-block/parted/parted-3.3-r1.ebuild b/sys-block/parted/parted-3.3-r1.ebuild
index 6fcef66453c2..2ca81e874d85 100644
--- a/sys-block/parted/parted-3.3-r1.ebuild
+++ b/sys-block/parted/parted-3.3-r1.ebuild
@@ -7,22 +7,20 @@ inherit flag-o-matic
DESCRIPTION="Create, destroy, resize, check, copy partitions and file systems"
HOMEPAGE="https://www.gnu.org/software/parted"
-SRC_URI="
- mirror://gnu/${PN}/${P}.tar.xz
-"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="+debug device-mapper nls readline selinux static-libs"
-RESTRICT="test"
+IUSE="+debug device-mapper nls readline selinux"
-# specific version for gettext needed
-# to fix bug 85999
RDEPEND="
>=sys-fs/e2fsprogs-1.27
device-mapper? ( >=sys-fs/lvm2-2.02.45 )
- readline? ( >=sys-libs/readline-5.2:0= >=sys-libs/ncurses-5.7-r7:0= )
+ readline? (
+ >=sys-libs/ncurses-5.7-r7:0=
+ >=sys-libs/readline-5.2:0=
+ )
selinux? ( sys-libs/libselinux )
elibc_uclibc? ( dev-libs/libiconv )
"
@@ -43,20 +41,23 @@ src_prepare() {
src_configure() {
use elibc_uclibc && append-libs -liconv
- econf \
- $(use_enable debug) \
- $(use_enable device-mapper) \
- $(use_enable nls) \
- $(use_enable selinux) \
- $(use_enable static-libs static) \
- $(use_with readline) \
+ local myconf=(
+ $(use_enable debug)
+ $(use_enable device-mapper)
+ $(use_enable nls)
+ $(use_enable selinux)
+ $(use_with readline)
--disable-rpath
+ --disable-static
+ )
+ econf "${myconf[@]}"
}
-DOCS=( AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/{API,FAT,USER.jp} )
+DOCS=(
+ AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/{API,FAT,USER.jp}
+)
src_install() {
default
-
find "${D}" -name '*.la' -delete || die
}