summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/gnu-efi/gnu-efi-3.0.3.ebuild')
-rw-r--r--sys-boot/gnu-efi/gnu-efi-3.0.3.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-boot/gnu-efi/gnu-efi-3.0.3.ebuild b/sys-boot/gnu-efi/gnu-efi-3.0.3.ebuild
new file mode 100644
index 000000000000..508f0a9b236b
--- /dev/null
+++ b/sys-boot/gnu-efi/gnu-efi-3.0.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib
+
+DESCRIPTION="Library for build EFI Applications"
+HOMEPAGE="http://gnu-efi.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gnu-efi/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64 ~ia64 ~x86"
+IUSE=""
+
+DEPEND="sys-apps/pciutils"
+RDEPEND=""
+
+# These objects get run early boot (i.e. not inside of Linux),
+# so doing these QA checks on them doesn't make sense.
+QA_EXECSTACK="usr/*/lib*efi.a:* usr/*/crt*.o"
+
+_emake() {
+ emake \
+ prefix=${CHOST}- \
+ ARCH=${iarch} \
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR='$(PREFIX)/'"$(get_libdir)" \
+ "$@"
+}
+
+src_compile() {
+ case ${ARCH} in
+ ia64) iarch=ia64 ;;
+ x86) iarch=ia32 ;;
+ amd64) iarch=x86_64 ;;
+ *) die "unknown architecture: $ARCH" ;;
+ esac
+ # The lib subdir uses unsafe archive targets, and
+ # the apps subdir needs gnuefi subdir
+ _emake -j1
+}
+
+src_install() {
+ _emake install PREFIX=/usr INSTALLROOT="${D}"
+ dodoc README* ChangeLog
+}