summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/lilo/files')
-rw-r--r--sys-boot/lilo/files/lilo-22.8-correct-usage-info.patch12
-rw-r--r--sys-boot/lilo/files/lilo-22.8-makefile.patch42
-rw-r--r--sys-boot/lilo/files/lilo-22.8-nodevmapper.patch13
-rw-r--r--sys-boot/lilo/files/lilo-22.8-novga.patch11
-rw-r--r--sys-boot/lilo/files/lilo-23.0-make.patch103
-rw-r--r--sys-boot/lilo/files/lilo-24.0-novga.patch12
-rw-r--r--sys-boot/lilo/files/lilo-24.1-novga.patch12
-rw-r--r--sys-boot/lilo/files/lilo.conf73
8 files changed, 278 insertions, 0 deletions
diff --git a/sys-boot/lilo/files/lilo-22.8-correct-usage-info.patch b/sys-boot/lilo/files/lilo-22.8-correct-usage-info.patch
new file mode 100644
index 000000000000..87ea4b20ce9e
--- /dev/null
+++ b/sys-boot/lilo/files/lilo-22.8-correct-usage-info.patch
@@ -0,0 +1,12 @@
+--- a/lilo.c
++++ b/lilo.c
+@@ -548,7 +548,8 @@
+ fprintf(errstd,"%7s%s -T help \t\t\tlist additional options\n", "", name);
+ fprintf(errstd,"%7s%s -X\t\t\t\tinternal compile-time options\n", "", name);
+ #endif /* !__MSDOS__ */
+- fprintf(errstd,"%7s%s -V [ -v ]\t\t\tversion information\n\n","",name);
++ fprintf(errstd,"%7s%s -V\t\t\t\tversion information\n","",name);
++ fprintf(errstd,"%7s%s -v\t\t\t\tverbose mode\n\n","",name);
+ exit(1);
+ }
+
diff --git a/sys-boot/lilo/files/lilo-22.8-makefile.patch b/sys-boot/lilo/files/lilo-22.8-makefile.patch
new file mode 100644
index 000000000000..d2a34bbded1d
--- /dev/null
+++ b/sys-boot/lilo/files/lilo-22.8-makefile.patch
@@ -0,0 +1,42 @@
+--- a/Makefile
++++ b/Makefile
+@@ -69,18 +69,7 @@
+ -DMDPRAID -DDEVMAPPER
+
+
+-# set the following if you wish LILO.COM to be installed
+-DOS_DIR=/dosC/boot
+-#
+-# select one of the following to place the man pages in the right place
+-#MAN_DIR=`if [ -z "$(whereis lilo | grep 'lilo.8')" ]; then \
+-# whereis lilo | sed -e "sX.* /usrX/usrX" -e "sX/man8/lilo.8.*XX" ; \
+-# elif [ -f /usr/bin/manpath ]; then \
+-# manpath | sed "s/:.*//"; else echo /usr/man; fi`
+-#
+-MAN_DIR=`if [ -f /usr/bin/manpath ]; then \
+- manpath | sed "s/:.*//"; else echo /usr/share/man; fi`
+-#MAN_DIR=/usr/share/man
++MAN_DIR=/usr/share/man
+
+ # set the compiler optimization level
+
+@@ -165,10 +154,7 @@
+ #
+ # everything needed to run, just short of installation
+ #
+-all: lilo bootsect.b diag1.img # OBSOLETE: $(BOOTS) edit dparam.com activate
+- if [ -x /usr/bin/bcc -o -x /usr/local/bin/bcc ]; then \
+- make diagnostic; \
+- make dosexe; fi
++all: lilo
+
+ #
+ # everything above plus the statically linked version
+@@ -452,7 +438,6 @@
+ rm -f $$ROOT$(BOOT_DIR)/boot.b; fi
+ cp mkrescue $$ROOT$(SBIN_DIR)
+ cp lilo $$ROOT$(SBIN_DIR)
+- strip $$ROOT$(SBIN_DIR)/lilo
+ cp keytab-lilo.pl $$ROOT$(USRSBIN_DIR)
+ cp manPages/lilo.8 $$ROOT$(MAN_DIR)/man8
+ cp manPages/mkrescue.8 $$ROOT$(MAN_DIR)/man8
diff --git a/sys-boot/lilo/files/lilo-22.8-nodevmapper.patch b/sys-boot/lilo/files/lilo-22.8-nodevmapper.patch
new file mode 100644
index 000000000000..f81cbfe92ef5
--- /dev/null
+++ b/sys-boot/lilo/files/lilo-22.8-nodevmapper.patch
@@ -0,0 +1,13 @@
+--- Makefile~ 2007-04-28 22:04:23.000000000 +0200
++++ Makefile 2007-04-28 22:21:46.000000000 +0200
+@@ -91,8 +91,8 @@
+ sed 's/-D/-DLCF_/g'`
+ LILO=-DLILO=0xbb920890
+ KVER=`if [ -f /usr/include/linux/version.h ]; then echo -DHAS_VERSION_H; fi`
+-HDM=`if [ -f /usr/include/libdevmapper.h ]; then echo -DHAS_LIBDEVMAPPER_H; fi`
+-DEVMAPPER=`if [ -f /usr/include/libdevmapper.h ]; then echo "-ldevmapper"; fi`
++HDM=
++DEVMAPPER=
+
+ TMP=_TmP_
+
diff --git a/sys-boot/lilo/files/lilo-22.8-novga.patch b/sys-boot/lilo/files/lilo-22.8-novga.patch
new file mode 100644
index 000000000000..939998fe9d4e
--- /dev/null
+++ b/sys-boot/lilo/files/lilo-22.8-novga.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -66,7 +66,7 @@
+
+ CONFIG=-DBDATA -DDSECS=3 -DEVMS -DIGNORECASE -DLVM -DNOKEYBOARD -DONE_SHOT \
+ -DPASS160 -DREISERFS -DREWRITE_TABLE -DSOLO_CHAIN -DVERSION -DVIRTUAL \
+- -DMDPRAID -DDEVMAPPER
++ -DMDPRAID -DDEVMAPPER -DNOVGA
+
+
+ MAN_DIR=/usr/share/man
diff --git a/sys-boot/lilo/files/lilo-23.0-make.patch b/sys-boot/lilo/files/lilo-23.0-make.patch
new file mode 100644
index 000000000000..00b15c52ca07
--- /dev/null
+++ b/sys-boot/lilo/files/lilo-23.0-make.patch
@@ -0,0 +1,103 @@
+--- a/Makefile 2010-06-18 19:17:48.000000000 +0200
++++ b/Makefile 2010-07-20 02:00:18.000000000 +0200
+@@ -26,19 +26,19 @@
+ # everything needed to run, just short of installation
+ #
+ all: test
+- make -C src all
++ $(MAKE) -C src all
+
+ #
+ # everything above plus the statically linked version
+ #
+ alles: test
+- make -C src alles
++ $(MAKE) -C src alles
+
+ #
+ # documentation files
+ #
+ docs:
+- make -C doc all
++ $(MAKE) -C doc all
+
+ #
+ # if you have the 'bcc' compiler, then you can make the diagnostics, too
+@@ -55,23 +55,23 @@
+ @echo before you proceed from this point.
+ @echo "Press <Enter> to continue, <^C> to abort ..."
+ @read
+- @make -C src floppy1
++ @$(MAKE) -C src floppy1
+ @echo Done.
+ @echo
+ @echo Remove the floppy from the drive. Label it "\"1.6\""
+ @echo "Press <Enter> to continue, <^C> to abort ..."
+ @read
+- @make -C src floppy2
++ @$(MAKE) -C src floppy2
+ @echo Done.
+ @echo
+ @echo Remove the floppy from the drive. Label it "\"2.4\""
+ @echo
+
+ diagnostic: test
+- make -C src diagnostic
++ $(MAKE) -C src diagnostic
+
+ dosexe: test
+- make -C dos lilo
++ $(MAKE) -C dos lilo
+
+ #
+ # test for compilers & utilities
+@@ -85,33 +85,33 @@
+ # shorthand install, if one knows that one has the 'bcc' compiler
+ #
+ ins:
+- make -C src ins
++ $(MAKE) -C src ins
+
+ #
+ # normal install, but doesn't make the diagnostic binaries
+ #
+ install: all
+- make -C src install
+- make -C man install
+- make -C dos install
+- make -C src insobs
++ $(MAKE) -C src install
++ $(MAKE) -C man install
++ $(MAKE) -C dos install
++ $(MAKE) -C src insobs
+
+ tidy:
+- make -C src tidy
+- make -C diagnose tidy
+- make -C dos tidy
+- make -C doc tidy
++ $(MAKE) -C src tidy
++ $(MAKE) -C diagnose tidy
++ $(MAKE) -C dos tidy
++ $(MAKE) -C doc tidy
+
+ clean: tidy
+ rm -f test.img
+- make -C src clean
+- make -C diagnose clean
+- make -C dos clean
++ $(MAKE) -C src clean
++ $(MAKE) -C diagnose clean
++ $(MAKE) -C dos clean
+
+ spotless: distclean
+ distclean: clean
+- make -C src distclean
+- make -C diagnose distclean
+- make -C dos distclean
+- make -C doc clean
++ $(MAKE) -C src distclean
++ $(MAKE) -C diagnose distclean
++ $(MAKE) -C dos distclean
++ $(MAKE) -C doc clean
+
diff --git a/sys-boot/lilo/files/lilo-24.0-novga.patch b/sys-boot/lilo/files/lilo-24.0-novga.patch
new file mode 100644
index 000000000000..ebb06b486818
--- /dev/null
+++ b/sys-boot/lilo/files/lilo-24.0-novga.patch
@@ -0,0 +1,12 @@
+diff -ur lilo-23.2/make.vars lilo-23.2.new/make.vars
+--- lilo-23.2/make.vars 2013-01-18 11:33:02.438628138 -0600
++++ lilo-23.2.new/make.vars 2013-01-18 11:34:03.960697091 -0600
+@@ -71,7 +71,7 @@
+
+ CONFIG=-DBDATA -DDSECS=3 -DEVMS -DIGNORECASE -DLVM -DNOKEYBOARD -DONE_SHOT \
+ -DPASS160 -DREISERFS -DREWRITE_TABLE -DSOLO_CHAIN -DVERSION -DVIRTUAL \
+- -DMDPRAID -DDEVMAPPER
++ -DMDPRAID -DDEVMAPPER -DNOVGA
+
+ # set the following if you wish LILO.COM to be installed
+ DOS_DIR=/dosC/boot
diff --git a/sys-boot/lilo/files/lilo-24.1-novga.patch b/sys-boot/lilo/files/lilo-24.1-novga.patch
new file mode 100644
index 000000000000..512fac694fdb
--- /dev/null
+++ b/sys-boot/lilo/files/lilo-24.1-novga.patch
@@ -0,0 +1,12 @@
+diff -uNr lilo-24.1.ORIG/make.vars lilo-24.1/make.vars
+--- lilo-24.1.ORIG/make.vars 2015-01-22 10:36:54.656904227 +0000
++++ lilo-24.1/make.vars 2015-01-22 10:37:16.516903935 +0000
+@@ -71,7 +71,7 @@
+
+ CONFIG=-DBDATA -DDSECS=3 -DEVMS -DIGNORECASE -DLVM -DNOKEYBOARD -DONE_SHOT \
+ -DPASS160 -DREISERFS -DREWRITE_TABLE -DSOLO_CHAIN -DVERSION -DVIRTUAL \
+- -DMDPRAID -DDEVMAPPER
++ -DMDPRAID -DDEVMAPPER -DNOVGA
+
+ # set the following if you wish LILO.COM to be installed
+ DOS_DIR=/dosC/boot
diff --git a/sys-boot/lilo/files/lilo.conf b/sys-boot/lilo/files/lilo.conf
new file mode 100644
index 000000000000..1c0c48acc19a
--- /dev/null
+++ b/sys-boot/lilo/files/lilo.conf
@@ -0,0 +1,73 @@
+# $Id$
+# Author: Ultanium
+
+#
+# Start LILO global section
+#
+
+# Faster, but won't work on all systems:
+#compact
+# Should work for most systems, and do not have the sector limit:
+lba32
+# If lba32 do not work, use linear:
+#linear
+
+# MBR to install LILO to:
+boot = /dev/hda
+map = /boot/.map
+
+# If you are having problems booting from a hardware raid-array
+# or have a unusual setup, try this:
+#disk=/dev/ataraid/disc0/disc bios=0x80 # see this as the first BIOS disk
+#disk=/dev/sda bios=0x81 # see this as the second BIOS disk
+#disk=/dev/hda bios=0x82 # see this as the third BIOS disk
+
+# Here you can select the secondary loader to install. A few
+# examples is:
+#
+# boot-text.b
+# boot-menu.b
+# boot-bmp.b
+#
+install = /boot/boot-menu.b # Note that for lilo-22.5.5 or later you
+ # do not need boot-{text,menu,bmp}.b in
+ # /boot, as they are linked into the lilo
+ # binary.
+
+menu-scheme=Wb
+prompt
+# If you always want to see the prompt with a 15 second timeout:
+#timeout=150
+delay = 50
+# Normal VGA console
+vga = normal
+# VESA console with size 1024x768x16:
+#vga = 791
+
+#
+# End LILO global section
+#
+
+#
+# Linux bootable partition config begins
+#
+image = /boot/bzImage
+ root = /dev/hda3
+ #root = /devices/discs/disc0/part3
+ label = Gentoo
+ read-only # read-only for checking
+#
+# Linux bootable partition config ends
+#
+
+#
+# DOS bootable partition config begins
+#
+other = /dev/hda1
+ #other = /devices/discs/disc0/part1
+ label = Windows
+ table = /dev/hda
+#
+# DOS bootable partition config ends
+#
+