summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/palo/files/palo-2.00-toolchain.patch')
-rw-r--r--sys-boot/palo/files/palo-2.00-toolchain.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/sys-boot/palo/files/palo-2.00-toolchain.patch b/sys-boot/palo/files/palo-2.00-toolchain.patch
new file mode 100644
index 000000000000..168031714bc9
--- /dev/null
+++ b/sys-boot/palo/files/palo-2.00-toolchain.patch
@@ -0,0 +1,22 @@
+--- a/palo/Makefile
++++ b/palo/Makefile
+@@ -10,9 +10,9 @@
+ OS := $(shell uname -s)
+ CC?=cc
+ ifeq ($(strip ${OS}),HP-UX)
+-CFLAGS=-g -O -I../include -I../lib -I$(PA)/include
++CFLAGS=-O -I../include -I../lib -I$(PA)/include
+ else
+-CFLAGS=-g -O -I../include -I../lib -D_FILE_OFFSET_BITS=64
++CFLAGS=-O -I../include -I../lib -D_FILE_OFFSET_BITS=64
+ endif
+
+ ifneq ("$(wildcard /etc/debian_version)","")
+@@ -22,7 +22,6 @@
+ endif
+
+ # LDFLAGS=-Wl,-Bstatic
+-LDFLAGS=
+
+ OFILES2=mkbootable.o elf64.o load.o paloio.o elf32.o error.o gzip.o
+