summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/palo/files/palo-2.12-gcc10.patch')
-rw-r--r--sys-boot/palo/files/palo-2.12-gcc10.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/sys-boot/palo/files/palo-2.12-gcc10.patch b/sys-boot/palo/files/palo-2.12-gcc10.patch
new file mode 100644
index 000000000000..7832fbeac942
--- /dev/null
+++ b/sys-boot/palo/files/palo-2.12-gcc10.patch
@@ -0,0 +1,11 @@
+--- a/ipl/Makefile
++++ b/ipl/Makefile
+@@ -39,7 +39,7 @@ endif
+ VPATH=../lib:.
+
+ AFLAGS = -I../lib
+-CFLAGS = -DIPL_LOADER -I. -I../lib -I../include -O2 -mdisable-fpregs -Wall -fno-delete-null-pointer-checks
++CFLAGS = -DIPL_LOADER -I. -I../lib -I../include -O2 -mdisable-fpregs -Wall -fno-delete-null-pointer-checks -fno-builtin
+ LDFLAGS = -N --section-start .init=0x60000 -e '$$START$$'
+
+ all: iplelf