summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/palo/palo-1.98.ebuild')
-rw-r--r--sys-boot/palo/palo-1.98.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-boot/palo/palo-1.98.ebuild b/sys-boot/palo/palo-1.98.ebuild
new file mode 100644
index 000000000000..570db77c2c32
--- /dev/null
+++ b/sys-boot/palo/palo-1.98.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="PALO : PArisc Linux Loader"
+HOMEPAGE="http://parisc-linux.org/ https://parisc.wiki.kernel.org/"
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/deller/${PN}.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~hppa"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.96-toolchain.patch
+)
+
+src_compile() {
+ local target
+ for target in '-C palo' '-C ipl' 'iplboot'; do
+ emake AR=$(tc-getAR) CC=$(tc-getCC) LD=$(tc-getLD) ${target}
+ done
+}
+
+src_install() {
+ into /
+ dosbin palo/palo
+
+ doman palo.8
+ dodoc TODO debian/changelog README.html
+
+ insinto /etc
+ doins "${FILESDIR}"/palo.conf
+
+ insinto /usr/share/palo
+ doins iplboot
+
+ insinto /etc/kernel/postinst.d/
+ insopts -m 0744
+ doins "${FILESDIR}"/99palo
+}