summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/palo/palo-2.15.ebuild')
-rw-r--r--sys-boot/palo/palo-2.15.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-boot/palo/palo-2.15.ebuild b/sys-boot/palo/palo-2.15.ebuild
new file mode 100644
index 000000000000..5d425944019f
--- /dev/null
+++ b/sys-boot/palo/palo-2.15.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="PALO: PArisc Linux Loader"
+HOMEPAGE="https://parisc.wiki.kernel.org/"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/deller/palo.git"
+ inherit git-r3
+else
+ SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/deller/${PN}.git/snapshot/${P}.tar.gz"
+ KEYWORDS="-* ~hppa"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~hppa"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.00-toolchain.patch
+)
+
+src_compile() {
+ local target
+ for target in '-C palo' '-C ipl' 'iplboot'; do
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)" LD="$(tc-getLD)" ${target}
+ done
+}
+
+src_install() {
+ into /
+ dosbin palo/palo
+
+ insinto /usr/share/palo
+ doins iplboot
+
+ insinto /etc
+ doins "${FILESDIR}"/palo.conf
+
+ insinto /etc/kernel/postinst.d
+ insopts -m 0744
+ doins "${FILESDIR}"/99palo
+
+ doman palo.8
+
+ dodoc TODO debian/changelog README.html
+}