summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/palo/palo-9999.ebuild')
-rw-r--r--sys-boot/palo/palo-9999.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/sys-boot/palo/palo-9999.ebuild b/sys-boot/palo/palo-9999.ebuild
index 1c733273f096..2b80fbe60c6d 100644
--- a/sys-boot/palo/palo-9999.ebuild
+++ b/sys-boot/palo/palo-9999.ebuild
@@ -1,16 +1,22 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit git-r3 toolchain-funcs
-DESCRIPTION="PALO : PArisc Linux Loader"
-HOMEPAGE="http://parisc-linux.org/ https://parisc.wiki.kernel.org/"
-EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/deller/palo.git"
+inherit toolchain-funcs
+
+DESCRIPTION="PALO: PArisc Linux Loader"
+HOMEPAGE="https://parisc.wiki.kernel.org/"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/deller/palo.git"
+ inherit git-r3
+else
+ SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/deller/${PN}.git/snapshot/${P}.tar.gz"
+ KEYWORDS="-* ~hppa"
+fi
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
PATCHES=(
"${FILESDIR}"/${PN}-2.00-toolchain.patch
@@ -19,7 +25,7 @@ PATCHES=(
src_compile() {
local target
for target in '-C palo' '-C ipl' 'iplboot'; do
- emake AR=$(tc-getAR) CC=$(tc-getCC) LD=$(tc-getLD) ${target}
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)" LD="$(tc-getLD)" ${target}
done
}