summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/raspberrypi-firmware/Manifest3
-rw-r--r--sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20201022.ebuild72
-rw-r--r--sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20201201.ebuild72
-rw-r--r--sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20210108.ebuild72
4 files changed, 0 insertions, 219 deletions
diff --git a/sys-boot/raspberrypi-firmware/Manifest b/sys-boot/raspberrypi-firmware/Manifest
index d8fa4686a378..5459cfbedfec 100644
--- a/sys-boot/raspberrypi-firmware/Manifest
+++ b/sys-boot/raspberrypi-firmware/Manifest
@@ -1,6 +1,3 @@
-DIST raspberrypi-firmware-1.20201022.tar.gz 189827375 BLAKE2B 94c38f60d688c8e3ebab830912daccbb6c04bdd3d88f6ca0d07d85be0a6b12c53f0266b4c258ed4694f30bad5db30fb6d30feabfd0b7668735a9a806b820d325 SHA512 876758179df27109984b6c3f4849fdcdc6bdcc2769495fcc83c97fc3ff4d07b9f3cd58086be877503f72c9e5417d2be6d6c33bce4cbb3b862055117c9cc26db8
-DIST raspberrypi-firmware-1.20201201.tar.gz 189332299 BLAKE2B b3ec91f07b4713d26c29be5412d018a220129eef7ddf7c5c09d85e645c2c5754a95f13be7e690ab40648a982e3974cc760aa5b33c76612da836227d38c4ee3a5 SHA512 a7f4591552718956bd7f2d0d377234277e2e6f18cc9714ea30fe13f26d5ae1164b982f39dcf72ae4a18663369ef06d0187d8182713763262371c13107aac4c65
-DIST raspberrypi-firmware-1.20210108.tar.gz 189334002 BLAKE2B 254e8bf644b2b3773ff5ec9ffb47eeb84e0a149e9a74a18a9c6c39db03610fdd3a42f455a9e8935aa4afa4ee21ed098237d4a4e431c401a919c833372e729fa5 SHA512 3c8759e7d6cce597fcbab80e0cd9fd6d528ed2c956452e902f08509169181d703895298a71b8be76d6734f128f85e36d54a149ff9cd735ca44cf8416917ed172
DIST raspberrypi-firmware-1.20210527.tar.gz 192247084 BLAKE2B 329707dfb2905b36926a3f0ecf1a8e3bc2b52e1a376f98ca7cfe9ec7b69d0fb370d8e23907f5bbd9ea75cf7fed5babd6fe54934919995dec6914e888d95e5fbe SHA512 5a48d1fae768c30528359a14371f59564447d2fb8a145cafa89d7d29352095c5b7ac33bfcbc8da494284c9d41e7dbafe4e863e8efd963a17ea6b6b9699b814a7
DIST raspberrypi-firmware-1.20211029.tar.gz 193543221 BLAKE2B 308206d6bdfbe15bfe5f39cd230e6d4857f460744aafcbcc9eee6a74f05a3a9dc861e7c3e36baea46fdb1d1d1dc28b5edebf70bce3a3c085228b2ea321ef7a85 SHA512 7a1fe3b1645006c35fa49e842b9ece53b386ece42b8db99649de8d4bc0c19e34b0807767290e26422528606c5847843533aaa0edd0716e9f9f9dcae340a4dce0
DIST raspberrypi-firmware-1.20211118.tar.gz 193544570 BLAKE2B db6c7c2e247f668b02210fb181305c3244f3d8a30f923656bf15cf418cb26822844df5b39af62b483e9e49405e13a60e57d6826aa0f3c3698920e8fc568656e2 SHA512 54881fc31ca0c9de8d8ca41ad6418e9d149975fbadbc0409f4136d4a31e70d743d55a16d4c0942305077d463c952edaa48be56d22d015983ab672dcaf5f134e2
diff --git a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20201022.ebuild b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20201022.ebuild
deleted file mode 100644
index 9ed770d2e9df..000000000000
--- a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20201022.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit mount-boot readme.gentoo-r1
-
-if [[ "${PV}" == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/raspberrypi/firmware"
- EGIT_CLONE_TYPE="shallow"
-else
- SRC_URI="https://github.com/raspberrypi/firmware/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="-* arm arm64"
- S="${WORKDIR}/firmware-${PV}"
-fi
-
-DESCRIPTION="Raspberry Pi (all versions) bootloader and GPU firmware"
-HOMEPAGE="https://github.com/raspberrypi/firmware"
-
-LICENSE="GPL-2 raspberrypi-videocore-bin"
-SLOT="0"
-RESTRICT="binchecks strip"
-
-DOC_CONTENTS="Please configure your ram setup by editing /boot/config.txt"
-
-src_prepare() {
- default
-
- cp "${FILESDIR}"/${PN}-1.20201022-config.txt "${WORKDIR}" || die
-
- if use arm64; then
- # Force selection of the 64-bit kernel8.img to match our userland
- echo "arm_64bit=1" >> "${WORKDIR}"/${PN}-1.20201022-config.txt || die
- fi
-}
-
-src_install() {
- insinto /boot
- cd boot || die
- doins bootcode.bin fixup*.dat start*elf
- newins "${WORKDIR}"/${PN}-1.20201022-config.txt config.txt
- newins "${FILESDIR}"/${PN}-1.20201022-cmdline.txt cmdline.txt
- newenvd "${FILESDIR}"/${PN}-0_p20130711-envd 90${PN}
- readme.gentoo_create_doc
-}
-
-pkg_preinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]] ; then
- local msg=""
-
- if [[ -e "${ED}"/boot/cmdline.txt ]] && [[ -e /boot/cmdline.txt ]] ; then
- msg+="/boot/cmdline.txt "
- fi
-
- if [[ -e "${ED}"/boot/config.txt ]] && [[ -e /boot/config.txt ]] ; then
- msg+="/boot/config.txt "
- fi
-
- if [[ -n "${msg}" ]] ; then
- msg="This package installs following files: ${msg}."
- msg="${msg} Please remove (backup) your copies durning install"
- msg="${msg} and merge settings afterwards."
- msg="${msg} Further updates will be CONFIG_PROTECTed."
- die "${msg}"
- fi
- fi
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}
diff --git a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20201201.ebuild b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20201201.ebuild
deleted file mode 100644
index 43c2288dc321..000000000000
--- a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20201201.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit mount-boot readme.gentoo-r1
-
-if [[ "${PV}" == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/raspberrypi/firmware"
- EGIT_CLONE_TYPE="shallow"
-else
- SRC_URI="https://github.com/raspberrypi/firmware/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="-* arm arm64"
- S="${WORKDIR}/firmware-${PV}"
-fi
-
-DESCRIPTION="Raspberry Pi (all versions) bootloader and GPU firmware"
-HOMEPAGE="https://github.com/raspberrypi/firmware"
-
-LICENSE="GPL-2 raspberrypi-videocore-bin"
-SLOT="0"
-RESTRICT="binchecks strip"
-
-DOC_CONTENTS="Please configure your ram setup by editing /boot/config.txt"
-
-src_prepare() {
- default
-
- cp "${FILESDIR}"/${PN}-1.20201022-config.txt "${WORKDIR}" || die
-
- if use arm64; then
- # Force selection of the 64-bit kernel8.img to match our userland
- echo "arm_64bit=1" >> "${WORKDIR}"/${PN}-1.20201022-config.txt || die
- fi
-}
-
-src_install() {
- insinto /boot
- cd boot || die
- doins bootcode.bin fixup*.dat start*elf
- newins "${WORKDIR}"/${PN}-1.20201022-config.txt config.txt
- newins "${FILESDIR}"/${PN}-1.20201022-cmdline.txt cmdline.txt
- newenvd "${FILESDIR}"/${PN}-0_p20130711-envd 90${PN}
- readme.gentoo_create_doc
-}
-
-pkg_preinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]] ; then
- local msg=""
-
- if [[ -e "${ED}"/boot/cmdline.txt ]] && [[ -e /boot/cmdline.txt ]] ; then
- msg+="/boot/cmdline.txt "
- fi
-
- if [[ -e "${ED}"/boot/config.txt ]] && [[ -e /boot/config.txt ]] ; then
- msg+="/boot/config.txt "
- fi
-
- if [[ -n "${msg}" ]] ; then
- msg="This package installs following files: ${msg}."
- msg="${msg} Please remove (backup) your copies during install"
- msg="${msg} and merge settings afterwards."
- msg="${msg} Further updates will be CONFIG_PROTECTed."
- die "${msg}"
- fi
- fi
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}
diff --git a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20210108.ebuild b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20210108.ebuild
deleted file mode 100644
index 43c2288dc321..000000000000
--- a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20210108.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit mount-boot readme.gentoo-r1
-
-if [[ "${PV}" == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/raspberrypi/firmware"
- EGIT_CLONE_TYPE="shallow"
-else
- SRC_URI="https://github.com/raspberrypi/firmware/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="-* arm arm64"
- S="${WORKDIR}/firmware-${PV}"
-fi
-
-DESCRIPTION="Raspberry Pi (all versions) bootloader and GPU firmware"
-HOMEPAGE="https://github.com/raspberrypi/firmware"
-
-LICENSE="GPL-2 raspberrypi-videocore-bin"
-SLOT="0"
-RESTRICT="binchecks strip"
-
-DOC_CONTENTS="Please configure your ram setup by editing /boot/config.txt"
-
-src_prepare() {
- default
-
- cp "${FILESDIR}"/${PN}-1.20201022-config.txt "${WORKDIR}" || die
-
- if use arm64; then
- # Force selection of the 64-bit kernel8.img to match our userland
- echo "arm_64bit=1" >> "${WORKDIR}"/${PN}-1.20201022-config.txt || die
- fi
-}
-
-src_install() {
- insinto /boot
- cd boot || die
- doins bootcode.bin fixup*.dat start*elf
- newins "${WORKDIR}"/${PN}-1.20201022-config.txt config.txt
- newins "${FILESDIR}"/${PN}-1.20201022-cmdline.txt cmdline.txt
- newenvd "${FILESDIR}"/${PN}-0_p20130711-envd 90${PN}
- readme.gentoo_create_doc
-}
-
-pkg_preinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]] ; then
- local msg=""
-
- if [[ -e "${ED}"/boot/cmdline.txt ]] && [[ -e /boot/cmdline.txt ]] ; then
- msg+="/boot/cmdline.txt "
- fi
-
- if [[ -e "${ED}"/boot/config.txt ]] && [[ -e /boot/config.txt ]] ; then
- msg+="/boot/config.txt "
- fi
-
- if [[ -n "${msg}" ]] ; then
- msg="This package installs following files: ${msg}."
- msg="${msg} Please remove (backup) your copies during install"
- msg="${msg} and merge settings afterwards."
- msg="${msg} Further updates will be CONFIG_PROTECTed."
- die "${msg}"
- fi
- fi
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}