summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/ceph/files/ceph-16.2.0-jaeger-system-boost.patch')
-rw-r--r--sys-cluster/ceph/files/ceph-16.2.0-jaeger-system-boost.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/sys-cluster/ceph/files/ceph-16.2.0-jaeger-system-boost.patch b/sys-cluster/ceph/files/ceph-16.2.0-jaeger-system-boost.patch
new file mode 100644
index 000000000000..18d5d9c6d513
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-16.2.0-jaeger-system-boost.patch
@@ -0,0 +1,14 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 0a0d8672a7..a76e7e1842 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -631,6 +631,9 @@ if(WITH_SYSTEM_BOOST)
+ set_property(TARGET Boost::iostreams APPEND PROPERTY
+ INTERFACE_LINK_LIBRARIES ZLIB::ZLIB)
+ endif()
++ if (WITH_JAEGER)
++ include_directories("${CMAKE_SOURCE_DIR}/boost/include")
++ endif()
+ else()
+ set(BOOST_J 1 CACHE STRING
+ "max jobs for Boost build") # override w/-DBOOST_J=<n>