summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/crmsh/crmsh-4.2.1-r2.ebuild')
-rw-r--r--sys-cluster/crmsh/crmsh-4.2.1-r2.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/sys-cluster/crmsh/crmsh-4.2.1-r2.ebuild b/sys-cluster/crmsh/crmsh-4.2.1-r2.ebuild
deleted file mode 100644
index ffab4f2a9c1d..000000000000
--- a/sys-cluster/crmsh/crmsh-4.2.1-r2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8,9} )
-
-if [[ ${PV} == *9999 ]]; then
- EGIT_REPO_URI="https://github.com/crmsh/crmsh"
- inherit git-3
- S="${WORKDIR}/${PN}-${MY_TREE}"
-else
- SRC_URI="https://github.com/crmsh/crmsh/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~hppa ~x86"
-fi
-
-inherit autotools python-r1
-
-DESCRIPTION="Pacemaker command line interface for management and configuration"
-HOMEPAGE="https://crmsh.github.io/"
-
-LICENSE="GPL-2"
-SLOT="0"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}
- >=sys-cluster/pacemaker-1.1.9"
-RDEPEND="${DEPEND}
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/parallax[${PYTHON_USEDEP}]
-"
-
-src_prepare() {
- default
-
- eautoreconf
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- python_foreach_impl python_optimize
-}