summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/gasnet/gasnet-1.26.4.ebuild')
-rw-r--r--sys-cluster/gasnet/gasnet-1.26.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-cluster/gasnet/gasnet-1.26.4.ebuild b/sys-cluster/gasnet/gasnet-1.26.4.ebuild
new file mode 100644
index 000000000000..168cd0fec116
--- /dev/null
+++ b/sys-cluster/gasnet/gasnet-1.26.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+MY_P="${PN^^[gasn]}-${PV}"
+DESCRIPTION="Networking middleware for partitioned global address space (PGAS) language"
+HOMEPAGE="http://gasnet.lbl.gov/"
+SRC_URI="http://gasnet.lbl.gov/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="mpi threads"
+
+DEPEND="mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ find . \
+ \( -name Makefile.am -or -name "*.mak" \) \
+ -exec sed -i '/^docdir/s/^/#/' {} + || die
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable mpi) $(use_enable threads pthreads)
+}