summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/hpx/files/hpx-1.4.1-disable-failing-tests.patch')
-rw-r--r--sys-cluster/hpx/files/hpx-1.4.1-disable-failing-tests.patch157
1 files changed, 0 insertions, 157 deletions
diff --git a/sys-cluster/hpx/files/hpx-1.4.1-disable-failing-tests.patch b/sys-cluster/hpx/files/hpx-1.4.1-disable-failing-tests.patch
deleted file mode 100644
index 492cbaf23781..000000000000
--- a/sys-cluster/hpx/files/hpx-1.4.1-disable-failing-tests.patch
+++ /dev/null
@@ -1,157 +0,0 @@
-From 10577db8e8ca556dc98b1c0010b7e53416e22b22 Mon Sep 17 00:00:00 2001
-From: Kurt Kanzenbach <kurt@kmk-computers.de>
-Date: Tue, 17 Mar 2020 11:21:53 +0100
-Subject: [PATCH] tests: Disable failing tests
-
-Currently six tests are failing:
-
-|99% tests passed, 6 tests failed out of 712
-|
-|Total Test time (real) = 2268.99 sec
-|
-|The following tests FAILED:
-| 339 - tests.unit.modules.segmented_algorithms.distributed.tcp.partitioned_vector_adjacent_find1 (Failed)
-| 454 - tests.regressions.dynamic_counters_loaded_1508 (Failed)
-| 601 - tests.unit.component.launch_process (Timeout)
-| 678 - tests.unit.threads.distributed.tcp.thread_stacksize (Failed)
-| 681 - tests.unit.topology.numa_allocator (Failed)
-| 712 - tests.unit.parcelset.distributed.tcp.put_parcels_with_coalescing (Failed)
-
-Needs to be further investigated. Disable them for now.
-
-Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
----
- .../tests/unit/CMakeLists.txt | 2 +-
- tests/regressions/CMakeLists.txt | 2 +-
- tests/unit/component/CMakeLists.txt | 36 +++++++++----------
- tests/unit/parcelset/CMakeLists.txt | 2 +-
- tests/unit/threads/CMakeLists.txt | 2 +-
- tests/unit/topology/CMakeLists.txt | 6 ++--
- 6 files changed, 25 insertions(+), 25 deletions(-)
-
-diff --git a/libs/segmented_algorithms/tests/unit/CMakeLists.txt b/libs/segmented_algorithms/tests/unit/CMakeLists.txt
-index 1ed7dbd7798a..17d5e4cca3b4 100644
---- a/libs/segmented_algorithms/tests/unit/CMakeLists.txt
-+++ b/libs/segmented_algorithms/tests/unit/CMakeLists.txt
-@@ -7,7 +7,7 @@
- set(tests
- partitioned_vector_adjacent_difference1
- partitioned_vector_adjacent_difference2
-- partitioned_vector_adjacent_find1
-+ # partitioned_vector_adjacent_find1
- partitioned_vector_adjacent_find2
- partitioned_vector_all_of1
- partitioned_vector_all_of2
-diff --git a/tests/regressions/CMakeLists.txt b/tests/regressions/CMakeLists.txt
-index 5a70ab8bfc99..fa4574ee0bf3 100644
---- a/tests/regressions/CMakeLists.txt
-+++ b/tests/regressions/CMakeLists.txt
-@@ -25,7 +25,7 @@ foreach(subdir ${subdirs})
- endforeach()
-
- set(tests
-- dynamic_counters_loaded_1508
-+ # dynamic_counters_loaded_1508
- id_type_ref_counting_1032
- multiple_init
- multiple_init_2918
-diff --git a/tests/unit/component/CMakeLists.txt b/tests/unit/component/CMakeLists.txt
-index 8deacffedb7b..49511e82e478 100644
---- a/tests/unit/component/CMakeLists.txt
-+++ b/tests/unit/component/CMakeLists.txt
-@@ -29,25 +29,25 @@ set(tests
- )
-
- if(HPX_WITH_NETWORKING)
-- set(tests ${tests}
-- launch_process
-- )
-+ # set(tests ${tests}
-+ # launch_process
-+ # )
-
- # add executable needed for launch_process_test
-- add_hpx_executable(launched_process_test
-- INTERNAL_FLAGS
-- SOURCES launched_process.cpp
-- EXCLUDE_FROM_ALL
-- HPX_PREFIX ${HPX_BUILD_PREFIX}
-- FOLDER "Tests/Unit/Components"
-- COMPONENT_DEPENDENCIES launch_process_test_server)
--
-- set(launch_process_FLAGS
-- DEPENDENCIES iostreams_component process_component
-- launch_process_test_server_component)
-- set(launch_process_PARAMETERS
-- --launch=$<TARGET_FILE:launched_process_test>
-- --hpx:expect-connecting-localities)
-+ # add_hpx_executable(launched_process_test
-+ # INTERNAL_FLAGS
-+ # SOURCES launched_process.cpp
-+ # EXCLUDE_FROM_ALL
-+ # HPX_PREFIX ${HPX_BUILD_PREFIX}
-+ # FOLDER "Tests/Unit/Components"
-+ # COMPONENT_DEPENDENCIES launch_process_test_server)
-+
-+ # set(launch_process_FLAGS
-+ # DEPENDENCIES iostreams_component process_component
-+ # launch_process_test_server_component)
-+ # set(launch_process_PARAMETERS
-+ # --launch=$<TARGET_FILE:launched_process_test>
-+ # --hpx:expect-connecting-localities)
- endif()
-
- set(action_invoke_no_more_than_PARAMETERS
-@@ -123,5 +123,5 @@ foreach(test ${tests})
- endforeach()
-
- if(HPX_WITH_NETWORKING)
-- add_hpx_pseudo_dependencies(tests.unit.component.launch_process launched_process_test)
-+ # add_hpx_pseudo_dependencies(tests.unit.component.launch_process launched_process_test)
- endif()
-diff --git a/tests/unit/parcelset/CMakeLists.txt b/tests/unit/parcelset/CMakeLists.txt
-index 93c5844b9210..ec2ffacd0f99 100644
---- a/tests/unit/parcelset/CMakeLists.txt
-+++ b/tests/unit/parcelset/CMakeLists.txt
-@@ -16,7 +16,7 @@ set(put_parcels_FLAGS DEPENDENCIES iostreams_component)
- set(set_parcel_write_handler_PARAMETERS LOCALITIES 2)
-
- if(HPX_WITH_PARCEL_COALESCING)
-- set(tests ${tests} put_parcels_with_coalescing)
-+ # set(tests ${tests} put_parcels_with_coalescing)
- set(put_parcels_with_coalescing_PARAMETERS LOCALITIES 2)
- set(put_parcels_with_coalescing_FLAGS DEPENDENCIES iostreams_component parcel_coalescing)
- endif()
-diff --git a/tests/unit/threads/CMakeLists.txt b/tests/unit/threads/CMakeLists.txt
-index df0a1eff4dbb..d542d24136b7 100644
---- a/tests/unit/threads/CMakeLists.txt
-+++ b/tests/unit/threads/CMakeLists.txt
-@@ -17,7 +17,7 @@ set(tests
- thread_id
- thread_launching
- thread_mf
-- thread_stacksize
-+ # thread_stacksize
- thread_suspension_executor
- thread_yield
- )
-diff --git a/tests/unit/topology/CMakeLists.txt b/tests/unit/topology/CMakeLists.txt
-index 8a8a26b294fb..9f6311395c61 100644
---- a/tests/unit/topology/CMakeLists.txt
-+++ b/tests/unit/topology/CMakeLists.txt
-@@ -5,9 +5,9 @@
- # file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt)
-
- if (HPX_WITH_SHARED_PRIORITY_SCHEDULER AND HPX_WITH_CXX14_RETURN_TYPE_DEDUCTION)
-- set(tests ${tests}
-- numa_allocator
-- )
-+ # set(tests ${tests}
-+ # numa_allocator
-+ # )
-
- # NB. threads = -2 = threads = 'cores'
- # NB. threads = -1 = threads = 'all'
---
-2.24.1
-