summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/hpx/files/hpx-1.5.1-cmake.patch')
-rw-r--r--sys-cluster/hpx/files/hpx-1.5.1-cmake.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-cluster/hpx/files/hpx-1.5.1-cmake.patch b/sys-cluster/hpx/files/hpx-1.5.1-cmake.patch
new file mode 100644
index 000000000000..ab31178bbe6d
--- /dev/null
+++ b/sys-cluster/hpx/files/hpx-1.5.1-cmake.patch
@@ -0,0 +1,32 @@
+From 8bee06baabf24c4b8f48766dba5c76d1979c8ea6 Mon Sep 17 00:00:00 2001
+From: Kurt Kanzenbach <kurt@kmk-computers.de>
+Date: Sat, 19 Sep 2020 13:19:42 +0200
+Subject: [PATCH] tests: Remove unused cmake options
+
+This fixes the following warnings:
+
+| * One or more CMake variables were not used by the project:
+| * BOOST_ROOT
+| * SETUP_TYPE
+
+Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
+---
+ tests/unit/build/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/unit/build/CMakeLists.txt b/tests/unit/build/CMakeLists.txt
+index a4db8d4c927f..43bb766aced5 100644
+--- a/tests/unit/build/CMakeLists.txt
++++ b/tests/unit/build/CMakeLists.txt
+@@ -57,7 +57,7 @@ function(create_cmake_test name using_install_dir hpx_dir setup_type test_dir)
+ ${name}.make_configure
+ COMMAND
+ "${CMAKE_COMMAND}" -E chdir "${build_dir}" "${CMAKE_COMMAND}" ${test_dir}
+- -DHPX_DIR=${hpx_dir} -DBOOST_ROOT=${BOOST_ROOT}
++ -DHPX_DIR=${hpx_dir}
+ ${ADDITIONAL_CMAKE_OPTIONS} -DCMAKE_CXX_FLAGS=${CMAKE_CXX_FLAGS_SAFE}
+ -DCMAKE_BUILD_TYPE=$<CONFIGURATION>
+ VERBATIM
+--
+2.26.2
+