summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/knem/knem-9999.ebuild')
-rw-r--r--sys-cluster/knem/knem-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sys-cluster/knem/knem-9999.ebuild b/sys-cluster/knem/knem-9999.ebuild
index 135aad0a586b..6e9922630791 100644
--- a/sys-cluster/knem/knem-9999.ebuild
+++ b/sys-cluster/knem/knem-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,7 +6,7 @@ EAPI=6
inherit autotools linux-mod linux-info toolchain-funcs udev multilib
DESCRIPTION="High-Performance Intra-Node MPI Communication"
-HOMEPAGE="http://runtime.bordeaux.inria.fr/knem/"
+HOMEPAGE="http://knem.gforge.inria.fr/"
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://gforge.inria.fr/git/knem/knem.git"
inherit git-r3
@@ -33,6 +33,8 @@ BUILD_PARAMS="KDIR=${KERNEL_DIR}"
pkg_setup() {
linux-info_pkg_setup
+ CONFIG_CHECK="DMA_ENGINE"
+ check_extra_config
linux-mod_pkg_setup
ARCH="$(tc-arch-kernel)"
ABI="${KERNEL_ABI}"