summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/kubectl/kubectl-1.17.4.ebuild')
-rw-r--r--sys-cluster/kubectl/kubectl-1.17.4.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/sys-cluster/kubectl/kubectl-1.17.4.ebuild b/sys-cluster/kubectl/kubectl-1.17.4.ebuild
deleted file mode 100644
index f70139e33e0b..000000000000
--- a/sys-cluster/kubectl/kubectl-1.17.4.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit bash-completion-r1 go-module
-
-DESCRIPTION="CLI to run commands against Kubernetes clusters"
-HOMEPAGE="https://github.com/kubernetes/kubernetes https://kubernetes.io"
-SRC_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-DEPEND=">=dev-lang/go-1.13
- dev-go/go-bindata"
-
-RESTRICT="strip test"
-S="${WORKDIR}/kubernetes-${PV}"
-
-src_prepare() {
- default
- sed -i -e "/vendor\/github.com\/jteeuwen\/go-bindata\/go-bindata/d" -e "s/-s -w/-w/" hack/lib/golang.sh || die
- sed -i -e "/export PATH/d" hack/generate-bindata.sh || die
-}
-
-src_compile() {
- LDFLAGS="" emake -j1 WHAT=cmd/${PN} GOFLAGS=-v
- _output/bin/${PN} completion bash > ${PN}.bash || die
- _output/bin/${PN} completion zsh > ${PN}.zsh || die
-}
-
-src_install() {
- dobin _output/bin/${PN}
- newbashcomp ${PN}.bash ${PN}
- insinto /usr/share/zsh/site-functions
- newins ${PN}.zsh _${PN}
-}