summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/legion/legion-16.08.0.ebuild')
-rw-r--r--sys-cluster/legion/legion-16.08.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-cluster/legion/legion-16.08.0.ebuild b/sys-cluster/legion/legion-16.08.0.ebuild
new file mode 100644
index 000000000000..534945d1aed2
--- /dev/null
+++ b/sys-cluster/legion/legion-16.08.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A data-centric parallel programming system"
+HOMEPAGE="http://legion.stanford.edu/"
+SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gasnet +hwloc"
+
+DEPEND="
+ gasnet? ( sys-cluster/gasnet )
+ hwloc? ( sys-apps/hwloc )
+ "
+
+S="${WORKDIR}/${PN}-${P}"
+
+#https://github.com/StanfordLegion/legion/pull/166
+#https://github.com/StanfordLegion/legion/pull/167
+PATCHES=( "${FILESDIR}/${P}-hwloc.patch" "${FILESDIR}/${P}-multilib.patch" )
+
+src_configure() {
+ mycmakeargs=(
+ -DLegion_USE_HWLOC=$(usex hwloc)
+ -DLegion_USE_GASNet=$(usex gasnet)
+ -DLIB=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}