summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/minikube')
-rw-r--r--sys-cluster/minikube/Manifest2
-rw-r--r--sys-cluster/minikube/minikube-0.26.1.ebuild43
-rw-r--r--sys-cluster/minikube/minikube-0.27.0.ebuild43
3 files changed, 0 insertions, 88 deletions
diff --git a/sys-cluster/minikube/Manifest b/sys-cluster/minikube/Manifest
index bbdb2c7b3da9..b9ac4a985914 100644
--- a/sys-cluster/minikube/Manifest
+++ b/sys-cluster/minikube/Manifest
@@ -1,3 +1 @@
-DIST minikube-0.26.1.tar.gz 20349450 BLAKE2B 18c2cab52b2cb6f4361a9f8fbb1416370eb9f4f3b1bc8e65f76e08cfe685fa55c3c41b421080a94250c81b315aa72be4c8340f6d2623b0335b67ec66a3931cd8 SHA512 9e68609c8fc5ff98be06952529f8c1a34180b71017c8f8680233e34985a3a22e1083cbd6576d8d2152488509a45c97e17fff7c0689c01467e92ef6f26c679a14
-DIST minikube-0.27.0.tar.gz 20349013 BLAKE2B 2467917776b14644d47c75a72719291ba573ff797fb305169d14e5a1d9c3a1df176cc672d22698db9f14a748fdba5224e74701de8e9f91a7ca45dfc45a9e2977 SHA512 77553c9259648d59b0bcaaab44f0cbfc0d4c2ebbcd2dcdd50a4a1e1102743ffea8288a93d9165ae9e38724339124b08e0e9ae04e7ddc415f0548ec81cfced418
DIST minikube-0.28.0.tar.gz 20350636 BLAKE2B 002bf7a45483a724d9ebc4f2fa3bad5b9451d9d550211e3e93f8b75555a39358fe11798d0c4b1632c3235ee21e82adc18c9b2f6f4ba9590eb998901f870b7d52 SHA512 bbcc8540b9d64a0ac9da93f912d44c66991d8377fdb96b02a656a8919347b4dd40669c08850582ea54adce6b1ef132c41376f21f4e3cc07e5776df9a3286f4e7
diff --git a/sys-cluster/minikube/minikube-0.26.1.ebuild b/sys-cluster/minikube/minikube-0.26.1.ebuild
deleted file mode 100644
index 3f64627d6490..000000000000
--- a/sys-cluster/minikube/minikube-0.26.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-
-inherit python-any-r1 golang-build golang-vcs-snapshot
-
-EGO_PN="k8s.io/minikube"
-ARCHIVE_URI="https://github.com/kubernetes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64"
-
-DESCRIPTION="Single Node Kubernetes Cluster"
-HOMEPAGE="https://github.com/kubernetes/minikube https://kubernetes.io"
-SRC_URI="${ARCHIVE_URI}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="hardened"
-
-DEPEND="dev-go/go-bindata
- ${PYTHON_DEPS}"
-RDEPEND=">=sys-cluster/kubectl-1.9.4"
-
-RESTRICT="test"
-
-src_prepare() {
- default
- sed -i -e 's/ -s -w/ -w/' -e 's#GOBIN=$(GOPATH)/bin go get github.com/jteeuwen/go-bindata/...##' -e 's#$(GOPATH)/bin/go-bindata#/usr/bin/go-bindata#g' src/${EGO_PN}/Makefile || die
- sed -i -e "s/get_commit(), get_tree_state(), get_version()/get_commit(), 'gitTreeState=clean', get_version()/" src/${EGO_PN}/hack/get_k8s_version.py || die
-}
-
-src_compile() {
- export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')"
- LDFLAGS="" GOPATH="${WORKDIR}/${P}" emake -C src/${EGO_PN}
-}
-
-src_install() {
- pushd src/${EGO_PN} || die
- dobin out/minikube
- dodoc -r docs CHANGELOG.md README.md
- popd || die
-}
diff --git a/sys-cluster/minikube/minikube-0.27.0.ebuild b/sys-cluster/minikube/minikube-0.27.0.ebuild
deleted file mode 100644
index 3f64627d6490..000000000000
--- a/sys-cluster/minikube/minikube-0.27.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-
-inherit python-any-r1 golang-build golang-vcs-snapshot
-
-EGO_PN="k8s.io/minikube"
-ARCHIVE_URI="https://github.com/kubernetes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64"
-
-DESCRIPTION="Single Node Kubernetes Cluster"
-HOMEPAGE="https://github.com/kubernetes/minikube https://kubernetes.io"
-SRC_URI="${ARCHIVE_URI}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="hardened"
-
-DEPEND="dev-go/go-bindata
- ${PYTHON_DEPS}"
-RDEPEND=">=sys-cluster/kubectl-1.9.4"
-
-RESTRICT="test"
-
-src_prepare() {
- default
- sed -i -e 's/ -s -w/ -w/' -e 's#GOBIN=$(GOPATH)/bin go get github.com/jteeuwen/go-bindata/...##' -e 's#$(GOPATH)/bin/go-bindata#/usr/bin/go-bindata#g' src/${EGO_PN}/Makefile || die
- sed -i -e "s/get_commit(), get_tree_state(), get_version()/get_commit(), 'gitTreeState=clean', get_version()/" src/${EGO_PN}/hack/get_k8s_version.py || die
-}
-
-src_compile() {
- export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')"
- LDFLAGS="" GOPATH="${WORKDIR}/${P}" emake -C src/${EGO_PN}
-}
-
-src_install() {
- pushd src/${EGO_PN} || die
- dobin out/minikube
- dodoc -r docs CHANGELOG.md README.md
- popd || die
-}