summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/poolmon')
-rw-r--r--sys-cluster/poolmon/Manifest1
-rw-r--r--sys-cluster/poolmon/files/poolmon.conf3
-rw-r--r--sys-cluster/poolmon/files/poolmon.init18
-rw-r--r--sys-cluster/poolmon/files/poolmon.logrotate6
-rw-r--r--sys-cluster/poolmon/metadata.xml11
-rw-r--r--sys-cluster/poolmon/poolmon-0.5.ebuild29
6 files changed, 68 insertions, 0 deletions
diff --git a/sys-cluster/poolmon/Manifest b/sys-cluster/poolmon/Manifest
new file mode 100644
index 000000000000..c6cb2893881f
--- /dev/null
+++ b/sys-cluster/poolmon/Manifest
@@ -0,0 +1 @@
+DIST poolmon-0.5.tar.gz 6902 SHA256 7418c1486e9cf34740ca82f72f32be97eeaeb4b4ddeda74ce1972ca4735ed6dc SHA512 17faa13e6b9b42f0913673598002aa5ad65e7d35b6ed4f5d6a1bb36d7fce630a7e9f1afc6979d7a098a2b66e5943901213b5617ba6190b5b7e1e9a6a55f6cbf5 WHIRLPOOL d72866b0675724eb2787818799152a94c75ee76351db96f36f4a1bd9c4ec1c90e2e314eb2acc980c90149ca82133c2369996a14dd4386718259e7700139414ba
diff --git a/sys-cluster/poolmon/files/poolmon.conf b/sys-cluster/poolmon/files/poolmon.conf
new file mode 100644
index 000000000000..930a58c9c012
--- /dev/null
+++ b/sys-cluster/poolmon/files/poolmon.conf
@@ -0,0 +1,3 @@
+# /etc/conf.d/poolmon
+# set poolmon commandline options
+OPTIONS=""
diff --git a/sys-cluster/poolmon/files/poolmon.init b/sys-cluster/poolmon/files/poolmon.init
new file mode 100644
index 000000000000..141554fa9b62
--- /dev/null
+++ b/sys-cluster/poolmon/files/poolmon.init
@@ -0,0 +1,18 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+start() {
+ local pidfile=/run/poolmon.pid
+ ebegin "Starting poolmon"
+ start-stop-daemon --pidfile "${pidfile}" --exec /usr/bin/poolmon -- ${OPTIONS}
+ eend $?
+}
+
+stop() {
+ local pidfile=/run/poolmon.pid
+ ebegin "Stopping poolmon"
+ start-stop-daemon --stop --pidfile "${pidfile}"
+ eend $?
+}
diff --git a/sys-cluster/poolmon/files/poolmon.logrotate b/sys-cluster/poolmon/files/poolmon.logrotate
new file mode 100644
index 000000000000..5925635a70c1
--- /dev/null
+++ b/sys-cluster/poolmon/files/poolmon.logrotate
@@ -0,0 +1,6 @@
+/var/log/poolmon.log {
+ missingok
+ postrotate
+ /bin/kill -HUP `cat /run/poolmon.pid 2> /dev/null` 2>/dev/null || true
+ endscript
+}
diff --git a/sys-cluster/poolmon/metadata.xml b/sys-cluster/poolmon/metadata.xml
new file mode 100644
index 000000000000..2b951263ab67
--- /dev/null
+++ b/sys-cluster/poolmon/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mschiff@gentoo.org</email>
+ <name>Marc Schiffbauer</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">brandond/poolmon</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-cluster/poolmon/poolmon-0.5.ebuild b/sys-cluster/poolmon/poolmon-0.5.ebuild
new file mode 100644
index 000000000000..cd2c7303c8cb
--- /dev/null
+++ b/sys-cluster/poolmon/poolmon-0.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A director mailserver pool monitoring script for Dovecot"
+HOMEPAGE="https://github.com/brandond/poolmon"
+SRC_URI="https://github.com/brandond/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ dev-perl/IO-Socket-SSL
+ net-mail/dovecot
+ "
+
+src_install() {
+ dobin poolmon
+ dodoc README
+ newinitd "${FILESDIR}"/poolmon.init poolmon
+ newconfd "${FILESDIR}"/poolmon.conf poolmon
+ insinto /etc/logrotate.d/
+ newins "${FILESDIR}"/poolmon.logrotate poolmon
+}