summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/teleport/teleport-2.2.1.ebuild')
-rw-r--r--sys-cluster/teleport/teleport-2.2.1.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/sys-cluster/teleport/teleport-2.2.1.ebuild b/sys-cluster/teleport/teleport-2.2.1.ebuild
index 3fafc3ed333d..90fddb344c0c 100644
--- a/sys-cluster/teleport/teleport-2.2.1.ebuild
+++ b/sys-cluster/teleport/teleport-2.2.1.ebuild
@@ -21,6 +21,7 @@ fi
LICENSE="Apache-2.0"
SLOT="0"
IUSE=""
+RESTRICT="test"
DEPEND="
app-arch/zip
@@ -51,3 +52,7 @@ src_install() {
systemd_dounit "${FILESDIR}"/${PN}.service
systemd_install_serviced "${FILESDIR}"/${PN}.service.conf ${PN}.service
}
+
+src_test() {
+ GOPATH="${S}" emake -C src/${EGO_PN%/*} test
+}