summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/teleport')
-rw-r--r--sys-cluster/teleport/Manifest1
-rw-r--r--sys-cluster/teleport/teleport-2.2.0.ebuild2
-rw-r--r--sys-cluster/teleport/teleport-2.2.1.ebuild2
-rw-r--r--sys-cluster/teleport/teleport-2.2.4.ebuild56
-rw-r--r--sys-cluster/teleport/teleport-9999.ebuild2
5 files changed, 60 insertions, 3 deletions
diff --git a/sys-cluster/teleport/Manifest b/sys-cluster/teleport/Manifest
index 0cd526ab748a..4d5b5f9f7430 100644
--- a/sys-cluster/teleport/Manifest
+++ b/sys-cluster/teleport/Manifest
@@ -1,2 +1,3 @@
DIST teleport-2.2.0.tar.gz 7229371 SHA256 b12bea0474a0ce5f4df10729607661b1afbecd5e95083835ccee7b54493c9452 SHA512 bec288983371bd3807b7ce994b1533a5e869d903251f8a8ce6315768a1d3ae95d72f832037345c36c9cd4789fbc449c54b86359988b1e74d4f46f9e0db6b3239 WHIRLPOOL 5b128fda80b1ce4afe60e10e6d5d9e83f621f6a405e713af7d1b988562038aa927c9f7c733a927a3aa724c261d058dba1fa75526dd2eb9051b1e6fe4c984004c
DIST teleport-2.2.1.tar.gz 7235188 SHA256 5a5c7be4615a3ef3e6915a4330b71cd063dd3a86013b8a72a5dbbca882eb28ac SHA512 011ffd8fdf42131455c32b8a8ed1ddee0181a8dcd3424dc9cf5ac96c53ce719d369e0bfac4392cc0dec14e78fed94732bbcb56c2db5987ee778ad29e4f7a749d WHIRLPOOL 988da053d7c85acfe1103696e33eff9fbb37d4feb5af580b1fb7b8995ca7ec449786c997619f81717816298b4cdc0bf26b823ac62b3c85ce72d3bdd783d02215
+DIST teleport-2.2.4.tar.gz 7234252 SHA256 25624d3b8dff987eab70cfadd0fe55a96d741ef8955064cd6e51e718da7f0363 SHA512 859bc34c90c4d1a504b9fa2958e49803c7af8bee3c2692d70590095ef0356a00cf963c5fc30613f3a7852b602fc7fbbd81ca99fc24ce51787f6d8d2e05af4762 WHIRLPOOL 4572b9b0cd9b84a579b99135759cd270d6b6c1f4590a990f3652bd4a80ce80f54e061564518500615ac77a321bebfd1476596a83e822b33a166fa1b3ae62311f
diff --git a/sys-cluster/teleport/teleport-2.2.0.ebuild b/sys-cluster/teleport/teleport-2.2.0.ebuild
index 50aac8796fe3..73701f3ef242 100644
--- a/sys-cluster/teleport/teleport-2.2.0.ebuild
+++ b/sys-cluster/teleport/teleport-2.2.0.ebuild
@@ -9,7 +9,7 @@ HOMEPAGE="https://gravitational.com/teleport"
EGO_PN="github.com/gravitational/${PN}/..."
-if [ ${PV} == "9999" ] ; then
+if [[ ${PV} == "9999" ]] ; then
inherit git-r3 golang-vcs
EGIT_REPO_URI="https://github.com/gravitational/${PN}.git"
else
diff --git a/sys-cluster/teleport/teleport-2.2.1.ebuild b/sys-cluster/teleport/teleport-2.2.1.ebuild
index 50aac8796fe3..73701f3ef242 100644
--- a/sys-cluster/teleport/teleport-2.2.1.ebuild
+++ b/sys-cluster/teleport/teleport-2.2.1.ebuild
@@ -9,7 +9,7 @@ HOMEPAGE="https://gravitational.com/teleport"
EGO_PN="github.com/gravitational/${PN}/..."
-if [ ${PV} == "9999" ] ; then
+if [[ ${PV} == "9999" ]] ; then
inherit git-r3 golang-vcs
EGIT_REPO_URI="https://github.com/gravitational/${PN}.git"
else
diff --git a/sys-cluster/teleport/teleport-2.2.4.ebuild b/sys-cluster/teleport/teleport-2.2.4.ebuild
new file mode 100644
index 000000000000..d4cdaf815da9
--- /dev/null
+++ b/sys-cluster/teleport/teleport-2.2.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils golang-build systemd user
+
+DESCRIPTION="Modern SSH server for teams managing distributed infrastructure"
+HOMEPAGE="https://gravitational.com/teleport"
+
+EGO_PN="github.com/gravitational/${PN}/..."
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3 golang-vcs
+ EGIT_REPO_URI="https://github.com/gravitational/${PN}.git"
+else
+ inherit golang-vcs-snapshot
+ SRC_URI="https://github.com/gravitational/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+RESTRICT="test"
+
+DEPEND="
+ app-arch/zip
+ >=dev-lang/go-1.8.3"
+RDEPEND=""
+
+src_compile() {
+ GOPATH="${S}" emake -C src/${EGO_PN%/*}
+ pushd src/${EGO_PN%/*}/web/dist >/dev/null || die
+ zip -qr "${S}/src/${EGO_PN%/*}/build/webassets.zip" . || die
+ popd >/dev/null || die
+ cat "${S}/src/${EGO_PN%/*}/build/webassets.zip" >> "src/${EGO_PN%/*}/build/${PN}" || die
+ zip -q -A "${S}/src/${EGO_PN%/*}/build/${PN}" || die
+}
+
+src_install() {
+ dodir /var/lib/${PN} /etc/${PN}
+ dobin src/${EGO_PN%/*}/build/{tsh,tctl,teleport}
+
+ insinto /etc/${PN}
+ doins "${FILESDIR}"/${PN}.yaml
+
+ newinitd "${FILESDIR}"/${PN}.init.d ${PN}
+ newconfd "${FILESDIR}"/${PN}.conf.d ${PN}
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ systemd_install_serviced "${FILESDIR}"/${PN}.service.conf ${PN}.service
+}
+
+src_test() {
+ GOPATH="${S}" emake -C src/${EGO_PN%/*} test
+}
diff --git a/sys-cluster/teleport/teleport-9999.ebuild b/sys-cluster/teleport/teleport-9999.ebuild
index 875028053444..99620ea66841 100644
--- a/sys-cluster/teleport/teleport-9999.ebuild
+++ b/sys-cluster/teleport/teleport-9999.ebuild
@@ -9,7 +9,7 @@ HOMEPAGE="https://gravitational.com/teleport"
EGO_PN="github.com/gravitational/${PN}/..."
-if [ ${PV} == "9999" ] ; then
+if [[ ${PV} == "9999" ]] ; then
inherit git-r3 golang-vcs
EGIT_REPO_URI="https://github.com/gravitational/${PN}.git"
else