summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/ucx/ucx-1.13.1.ebuild')
-rw-r--r--sys-cluster/ucx/ucx-1.13.1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sys-cluster/ucx/ucx-1.13.1.ebuild b/sys-cluster/ucx/ucx-1.13.1.ebuild
new file mode 100644
index 000000000000..382955d373c3
--- /dev/null
+++ b/sys-cluster/ucx/ucx-1.13.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+MY_PV=${PV/_/-}
+DESCRIPTION="Unified Communication X"
+HOMEPAGE="https://www.openucx.org"
+SRC_URI="https://github.com/openucx/ucx/releases/download/v${PV}/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 -riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="+numa +openmp"
+
+RDEPEND="
+ sys-libs/binutils-libs:=
+ numa? ( sys-process/numactl )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.13.0-drop-werror.patch
+ "${FILESDIR}"/${PN}-1.13.0-fix-bashisms.patch
+ "${FILESDIR}"/${PN}-1.13.0-fix-fcntl-include-musl.patch
+ "${FILESDIR}"/${PN}-1.13.0-cstdint-include.patch
+ "${FILESDIR}"/${PN}-1.13.0-binutils-2.39-ptr-typedef.patch
+)
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ BASE_CFLAGS="" econf \
+ --disable-compiler-opt \
+ --without-fuse3 \
+ --without-go \
+ $(use_enable numa) \
+ $(use_enable openmp)
+}
+
+src_compile() {
+ BASE_CFLAGS="" emake
+}