summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/openmpi/Manifest1
-rw-r--r--sys-cluster/openmpi/openmpi-4.1.2.ebuild187
2 files changed, 188 insertions, 0 deletions
diff --git a/sys-cluster/openmpi/Manifest b/sys-cluster/openmpi/Manifest
index 50e8cf0eeb0a..1fbf65fc91b7 100644
--- a/sys-cluster/openmpi/Manifest
+++ b/sys-cluster/openmpi/Manifest
@@ -13,3 +13,4 @@ DIST openmpi-4.0.5.tar.bz2 9752045 BLAKE2B 9709dc8c251d4f2be14d0ab498c5d0d0e59f9
DIST openmpi-4.0.6.tar.bz2 9805015 BLAKE2B 2a476fc22a953bd8afb56153ca73e86e27a60ea1490bc1f2ac2a800d352876504e474d8cf8fc768e447ea9840413d7ae9eb7d852c14b0d751b90b86a6133b194 SHA512 4900a957756399464a74e7f685d5d0bf2b4672e274dc02f7de3e5ac07d9e890713d20ef424e0810368ace2315a2d3dea727bfeca980eb2d7cc99f12979dde22d
DIST openmpi-4.0.7.tar.bz2 9809794 BLAKE2B c8ecafa3d50c54ebb9c8853010628240a696b342b04d17df66c4dbbc199a6b65bf7d92a8c34867e86e36a8664d1e26b7d0b0fa16f28cc9c8fed5223a4c06ef81 SHA512 27c49a1598c565e7ab63d2ca5b5277aad36f9f863854199e86af0387ec6edce9a99e9a8bc8dad565d01a6ab4c9f61067603c07b30a165317cced4997507727a4
DIST openmpi-4.1.1.tar.bz2 10052770 BLAKE2B 2f853ca44703197469e5ccd42ecd81de72d39f265e0da9d847e6b2f7a7646241b76346c71969bf6a3d4605c28f02de6b587fd0330c753ad7dec8503af0784b69 SHA512 0d85ba45a40c0879f266e5286615e2cf94eb3570f0a705194525821d5c85d460cefc3a2da8207e6e84c479d3d0da656e2342cc2d6f88c4b4577ca22bbeacc89d
+DIST openmpi-4.1.2.tar.bz2 10084596 BLAKE2B 2e6fc12b4564a302d2c364528d0f6bea8b23f9b1cd6059763b8d5de583d86aae2812c239b1d0bb40c83f3c7682c8e666ce1de3112e95de54848169cb5e2805e8 SHA512 1958f96434cddbe525b4511fcf8d0cf8bf1ff376e024466219bd3a2092900e318f45a4b1e1a8ef6b03e350f46a71777fc7db82a7df711f12bb9758150d209aad
diff --git a/sys-cluster/openmpi/openmpi-4.1.2.ebuild b/sys-cluster/openmpi/openmpi-4.1.2.ebuild
new file mode 100644
index 000000000000..6652c805f75a
--- /dev/null
+++ b/sys-cluster/openmpi/openmpi-4.1.2.ebuild
@@ -0,0 +1,187 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+FORTRAN_NEEDED=fortran
+
+inherit cuda fortran-2 java-pkg-opt-2 multilib-minimal
+
+MY_P=${P/-mpi}
+S=${WORKDIR}/${MY_P}
+
+IUSE_OPENMPI_FABRICS="
+ openmpi_fabrics_ofed
+ openmpi_fabrics_knem
+ openmpi_fabrics_psm"
+
+IUSE_OPENMPI_RM="
+ openmpi_rm_pbs
+ openmpi_rm_slurm"
+
+IUSE_OPENMPI_OFED_FEATURES="
+ openmpi_ofed_features_control-hdr-padding
+ openmpi_ofed_features_udcm
+ openmpi_ofed_features_rdmacm
+ openmpi_ofed_features_dynamic-sl"
+
+DESCRIPTION="A high-performance message passing library (MPI)"
+HOMEPAGE="https://www.open-mpi.org"
+SRC_URI="https://www.open-mpi.org/software/ompi/v$(ver_cut 1-2)/downloads/${MY_P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
+IUSE="cma cuda cxx fortran heterogeneous ipv6 java libompitrace peruse romio
+ ${IUSE_OPENMPI_FABRICS} ${IUSE_OPENMPI_RM} ${IUSE_OPENMPI_OFED_FEATURES}"
+
+REQUIRED_USE="openmpi_rm_slurm? ( !openmpi_rm_pbs )
+ openmpi_rm_pbs? ( !openmpi_rm_slurm )
+ openmpi_fabrics_psm? ( openmpi_fabrics_ofed )
+ openmpi_ofed_features_control-hdr-padding? ( openmpi_fabrics_ofed )
+ openmpi_ofed_features_udcm? ( openmpi_fabrics_ofed )
+ openmpi_ofed_features_rdmacm? ( openmpi_fabrics_ofed )
+ openmpi_ofed_features_dynamic-sl? ( openmpi_fabrics_ofed )"
+
+CDEPEND="
+ !sys-cluster/mpich
+ !sys-cluster/mpich2
+ !sys-cluster/nullmpi
+ >=dev-libs/libevent-2.0.22:=[${MULTILIB_USEDEP},threads]
+ dev-libs/libltdl:0[${MULTILIB_USEDEP}]
+ >=sys-apps/hwloc-2.0.2:=[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ cuda? ( >=dev-util/nvidia-cuda-toolkit-6.5.19-r1:= )
+ openmpi_fabrics_ofed? ( || ( sys-cluster/rdma-core sys-fabric/ofed:* ) )
+ openmpi_fabrics_knem? ( sys-cluster/knem )
+ openmpi_fabrics_psm? ( sys-fabric/infinipath-psm:* )
+ openmpi_rm_pbs? ( sys-cluster/torque )
+ openmpi_rm_slurm? ( sys-cluster/slurm )
+ openmpi_ofed_features_rdmacm? ( || ( sys-cluster/rdma-core sys-fabric/librdmacm:* ) )"
+
+RDEPEND="${CDEPEND}
+ java? ( >=virtual/jre-1.8:* )"
+
+DEPEND="${CDEPEND}
+ java? ( >=virtual/jdk-1.8:* )"
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/mpi.h
+ /usr/include/openmpi/ompi/mpi/java/mpiJava.h
+ /usr/include/openmpi/mpiext/mpiext_cuda_c.h
+)
+
+pkg_setup() {
+ fortran-2_pkg_setup
+ java-pkg-opt-2_pkg_setup
+
+ elog
+ elog "OpenMPI has an overwhelming count of configuration options."
+ elog "Don't forget the EXTRA_ECONF environment variable can let you"
+ elog "specify configure options if you find them necessary."
+ elog
+}
+
+src_prepare() {
+ default
+
+ echo "void main() { return 0; }" > test/util/opal_path_nfs.c || die
+
+ # Necessary for scalibility, see
+ # http://www.open-mpi.org/community/lists/users/2008/09/6514.php
+ echo 'oob_tcp_listen_mode = listen_thread' \
+ >> opal/etc/openmpi-mca-params.conf || die
+}
+
+multilib_src_configure() {
+ if use java; then
+ # We must always build with the right -source and -target
+ # flags. Passing flags to javac isn't explicitly supported here
+ # but we can cheat by overriding the configure test for javac.
+ export ac_cv_path_JAVAC="$(java-pkg_get-javac) $(java-pkg_javac-args)"
+ fi
+
+ local myconf=(
+ --enable-mpi-fortran=$(usex fortran all no)
+ --enable-orterun-prefix-by-default
+ --enable-pretty-print-stacktrace
+
+ --sysconfdir="${EPREFIX}/etc/${PN}"
+
+ --with-hwloc="${EPREFIX}/usr"
+ --with-hwloc-libdir="${EPREFIX}/usr/$(get_libdir)"
+ --with-libltdl="${EPREFIX}/usr"
+ --with-libevent="${EPREFIX}/usr"
+ --with-libevent-libdir="${EPREFIX}/usr/$(get_libdir)"
+
+ $(use_enable cxx mpi-cxx)
+ $(use_enable heterogeneous)
+ $(use_enable ipv6)
+ $(use_enable libompitrace)
+ $(use_enable peruse)
+ $(use_enable romio io-romio)
+
+ $(use_with cma)
+
+ $(multilib_native_use_enable java mpi-java)
+ $(multilib_native_use_enable openmpi_ofed_features_control-hdr-padding openib-control-hdr-padding)
+ $(multilib_native_use_enable openmpi_ofed_features_rdmacm openib-rdmacm)
+ $(multilib_native_use_enable openmpi_ofed_features_udcm openib-udcm)
+ $(multilib_native_use_enable openmpi_ofed_features_dynamic-sl openib-dynamic-sl)
+
+ $(multilib_native_use_with cuda cuda "${EPREFIX}"/opt/cuda)
+ $(multilib_native_use_with openmpi_fabrics_ofed verbs "${EPREFIX}"/usr)
+ $(multilib_native_use_with openmpi_fabrics_knem knem "${EPREFIX}"/usr)
+ $(multilib_native_use_with openmpi_fabrics_psm psm "${EPREFIX}"/usr)
+ $(multilib_native_use_with openmpi_rm_pbs tm)
+ $(multilib_native_use_with openmpi_rm_slurm slurm)
+ )
+
+ CONFIG_SHELL="${BROOT}/bin/bash" ECONF_SOURCE=${S} econf "${myconf[@]}"
+}
+
+multilib_src_compile() {
+ emake V=1
+}
+
+multilib_src_test() {
+ # -j1: doesn't work with the default src_test as the dry run (-n) fails.
+ # Explicit listing of test/* subdirs modulo util because of nfs test fails
+ # due to sandbox and couldn't find a sane way to skip it.
+ emake -j1 -C test asm class datatype dss event monitoring mpool spc support threads
+}
+
+multilib_src_install() {
+ default
+
+ # fortran header cannot be wrapped (bug #540508), workaround part 1
+ if multilib_is_native_abi && use fortran; then
+ mkdir "${T}"/fortran || die
+ mv "${ED}"/usr/include/mpif* "${T}"/fortran || die
+ else
+ # some fortran files get installed unconditionally
+ rm \
+ "${ED}"/usr/include/mpif* \
+ "${ED}"/usr/bin/mpif* \
+ || die
+ fi
+}
+
+multilib_src_install_all() {
+ # fortran header cannot be wrapped (bug #540508), workaround part 2
+ if use fortran; then
+ mv "${T}"/fortran/mpif* "${ED}"/usr/include || die
+ fi
+
+ # Remove la files, no static libs are installed and we have pkg-config
+ find "${ED}" -name '*.la' -delete || die
+
+ if use java; then
+ local mpi_jar="${ED}"/usr/$(get_libdir)/mpi.jar
+ java-pkg_dojar "${mpi_jar}"
+ # We don't want to install the jar file twice
+ # so let's clean after ourselves.
+ rm "${mpi_jar}" || die
+ fi
+ einstalldocs
+}