summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/binutils-hppa64/binutils-hppa64-2.20.1.ebuild')
-rw-r--r--sys-devel/binutils-hppa64/binutils-hppa64-2.20.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sys-devel/binutils-hppa64/binutils-hppa64-2.20.1.ebuild b/sys-devel/binutils-hppa64/binutils-hppa64-2.20.1.ebuild
new file mode 100644
index 000000000000..7883f6a58259
--- /dev/null
+++ b/sys-devel/binutils-hppa64/binutils-hppa64-2.20.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+export CTARGET=hppa64-${CHOST#*-}
+
+PATCHVER="1.1"
+ELF2FLT_VER=""
+inherit toolchain-binutils
+
+DESCRIPTION="binutils package for building 64bit kernels on HPPA"
+
+KEYWORDS="-* hppa"
+
+src_install() {
+ toolchain-binutils_src_install
+
+ # tweak the default fake list a little bit
+ cd "${D}"/etc/env.d/binutils
+ sed -i '/FAKE_TARGETS=/s:"$: hppa64-linux":' ${CTARGET}-${BVER} || die
+}