summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/clang/clang-18.1.0_rc2.ebuild')
-rw-r--r--sys-devel/clang/clang-18.1.0_rc2.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/sys-devel/clang/clang-18.1.0_rc2.ebuild b/sys-devel/clang/clang-18.1.0_rc2.ebuild
index d351f9774a48..189ad24d33b1 100644
--- a/sys-devel/clang/clang-18.1.0_rc2.ebuild
+++ b/sys-devel/clang/clang-18.1.0_rc2.ebuild
@@ -33,10 +33,6 @@ RDEPEND="
"
BDEPEND="
${PYTHON_DEPS}
- doc? ( $(python_gen_cond_dep '
- dev-python/myst-parser[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- ') )
xml? ( virtual/pkgconfig )
"
PDEPEND="
@@ -55,6 +51,15 @@ LLVM_TEST_COMPONENTS=(
LLVM_USE_TARGETS=llvm
llvm.org_set_globals
+[[ -n ${LLVM_MANPAGE_DIST} ]] && BDEPEND+=" doc? ( "
+BDEPEND+="
+ $(python_gen_cond_dep '
+ dev-python/myst-parser[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ ')
+"
+[[ -n ${LLVM_MANPAGE_DIST} ]] && BDEPEND+=" ) "
+
# Multilib notes:
# 1. ABI_* flags control ABIs libclang* is built for only.
# 2. clang is always capable of compiling code for all ABIs for enabled