summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/crosstool-ng/crosstool-ng-1.24.0-r1.ebuild')
-rw-r--r--sys-devel/crosstool-ng/crosstool-ng-1.24.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-devel/crosstool-ng/crosstool-ng-1.24.0-r1.ebuild b/sys-devel/crosstool-ng/crosstool-ng-1.24.0-r1.ebuild
new file mode 100644
index 000000000000..f9859d8ffd57
--- /dev/null
+++ b/sys-devel/crosstool-ng/crosstool-ng-1.24.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="crosstool-ng is a tool to build cross-compiling toolchains"
+HOMEPAGE="https://crosstool-ng.github.io/"
+MY_P=${P/ct/crosstool}
+SRC_URI="http://ymorin.is-a-geek.org/download/crosstool-ng/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="net-misc/curl
+ dev-util/gperf
+ dev-vcs/cvs
+ dev-vcs/subversion"
+
+S="${WORKDIR}/crosstool-ng-${PV}"
+
+src_install() {
+ emake DESTDIR="${D}" install
+ use doc && mv "${D}"/usr/share/doc/crosstool-ng/crosstool-ng-${PVR} \
+ "${D}"/usr/share/doc/
+ rm -rf "${D}"/usr/share/doc/crosstool-ng
+}