summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/crosstool-ng/crosstool-ng-1.24.0-r2.ebuild')
-rw-r--r--sys-devel/crosstool-ng/crosstool-ng-1.24.0-r2.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/sys-devel/crosstool-ng/crosstool-ng-1.24.0-r2.ebuild b/sys-devel/crosstool-ng/crosstool-ng-1.24.0-r2.ebuild
index e9a93b214563..2e09d5c02c72 100644
--- a/sys-devel/crosstool-ng/crosstool-ng-1.24.0-r2.ebuild
+++ b/sys-devel/crosstool-ng/crosstool-ng-1.24.0-r2.ebuild
@@ -1,23 +1,24 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="8"
+EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
inherit python-single-r1
+DESCRIPTION="Versatile (cross-)toolchain generator"
HOMEPAGE="https://crosstool-ng.github.io/"
-DESCRIPTION="A versatile (cross-)toolchain generator."
-if [[ "${PV}" == 9999 ]] ; then
+if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/crosstool-ng/crosstool-ng.git"
inherit git-r3
else
SRC_URI="
-https://github.com/crosstool-ng/crosstool-ng/releases/download/${PN}-${PV/_rc/-rc}/${P}.tar.xz
-http://crosstool-ng.org/download/crosstool-ng/${P}.tar.xz
-"
- if [[ "${PV}" != *_rc* ]] ; then
+ https://github.com/crosstool-ng/crosstool-ng/releases/download/${PN}-${PV/_rc/-rc}/${P}.tar.xz
+ http://crosstool-ng.org/download/crosstool-ng/${P}.tar.xz
+ "
+
+ if [[ ${PV} != *_rc* ]] ; then
KEYWORDS="~amd64 ~x86"
fi
fi
@@ -49,15 +50,16 @@ BDEPEND="
subversion? ( dev-vcs/subversion )
wget? ( net-misc/wget )
"
-
RDEPEND="
${BDEPEND}
"
src_install() {
emake DESTDIR="${D}" install
+
use doc && mv "${D}/usr/share/doc/crosstool-ng/crosstool-ng-${PVR}" \
"${D}"/usr/share/doc/
+
rm -rf "${D}"/usr/share/doc/crosstool-ng
rm -rf "${D}/usr/share/man/man1/ct-ng.1.gz"
cp docs/ct-ng.1 "${D}/usr/share/man/man1/"