summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gcc/gcc-13.0.1_pre20230226.ebuild')
-rw-r--r--sys-devel/gcc/gcc-13.0.1_pre20230226.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/sys-devel/gcc/gcc-13.0.1_pre20230226.ebuild b/sys-devel/gcc/gcc-13.0.1_pre20230226.ebuild
index 6b843430b057..639814d14c9c 100644
--- a/sys-devel/gcc/gcc-13.0.1_pre20230226.ebuild
+++ b/sys-devel/gcc/gcc-13.0.1_pre20230226.ebuild
@@ -33,12 +33,14 @@ if ! tc_is_live && [[ -z ${TOOLCHAIN_USE_GIT_PATCHES} ]] ; then
KEYWORDS="~loong"
fi
-# Technically only if USE=hardened *too* right now, but no point in complicating it further.
-# If GCC is enabling CET by default, we need glibc to be built with support for it.
-# bug #830454
-RDEPEND="elibc_glibc? ( sys-libs/glibc[cet(-)?] )"
-DEPEND="${RDEPEND}"
-BDEPEND="${CATEGORY}/binutils[cet(-)?]"
+if [[ ${CATEGORY} != cross-* ]] ; then
+ # Technically only if USE=hardened *too* right now, but no point in complicating it further.
+ # If GCC is enabling CET by default, we need glibc to be built with support for it.
+ # bug #830454
+ RDEPEND="elibc_glibc? ( sys-libs/glibc[cet(-)?] )"
+ DEPEND="${RDEPEND}"
+ BDEPEND=">=${CATEGORY}/binutils-2.30[cet(-)?]"
+fi
src_prepare() {
local p upstreamed_patches=(