summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gdb/gdb-11.2.ebuild')
-rw-r--r--sys-devel/gdb/gdb-11.2.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/sys-devel/gdb/gdb-11.2.ebuild b/sys-devel/gdb/gdb-11.2.ebuild
index 9b5d95603631..393a0a0bf8c6 100644
--- a/sys-devel/gdb/gdb-11.2.ebuild
+++ b/sys-devel/gdb/gdb-11.2.ebuild
@@ -53,10 +53,10 @@ fi
IUSE="cet guile lzma multitarget nls +python +server source-highlight test vanilla xml xxhash"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-# ia64 kernel crashes when gdb testsuite is running
-# in fact, gdb's test suite needs some work to get passing.
+# In fact, gdb's test suite needs some work to get passing.
# See e.g. https://sourceware.org/gdb/wiki/TestingGDB.
# As of 11.2, on amd64: "# of unexpected failures 8600"
+# ia64 kernel crashes when gdb testsuite is running
RESTRICT="
ia64? ( test )
!test? ( test )
@@ -103,9 +103,8 @@ src_prepare() {
default
strip-linguas -u bfd/po opcodes/po
- export CC_FOR_BUILD="$(tc-getBUILD_CC)"
- # avoid using ancient termcap from host on Prefix systems
+ # Avoid using ancient termcap from host on Prefix systems
sed -i -e 's/termcap tinfow/tinfow/g' \
gdb/configure{.ac,} || die
}
@@ -134,7 +133,7 @@ src_configure() {
--with-pkgversion="$(gdb_branding)"
--with-bugurl='https://bugs.gentoo.org/'
--disable-werror
- # Disable modules that are in a combined binutils/gdb tree. #490566
+ # Disable modules that are in a combined binutils/gdb tree. bug #490566
--disable-{binutils,etc,gas,gold,gprof,ld}
# avoid automagic dependency on (currently prefix) systems
@@ -197,6 +196,8 @@ src_configure() {
# source-highlight is detected with pkg-config: bug #716558
export ac_cv_path_pkg_config_prog_path="$(tc-getPKG_CONFIG)"
+ export CC_FOR_BUILD="$(tc-getBUILD_CC)"
+
# ensure proper compiler is detected for Clang builds: bug #831202
export GCC_FOR_TARGET="${CC_FOR_TARGET:-$(tc-getCC)}"
@@ -208,7 +209,7 @@ src_install() {
find "${ED}"/usr -name libiberty.a -delete || die
- # Delete translations that conflict with binutils-libs. #528088
+ # Delete translations that conflict with binutils-libs. bug #528088
# Note: Should figure out how to store these in an internal gdb dir.
if use nls ; then
find "${ED}" \
@@ -252,7 +253,7 @@ src_install() {
# Remove shared info pages
rm -f "${ED}"/usr/share/info/{annotate,bfd,configure,standards}.info*
- if use python; then
+ if use python ; then
python_optimize "${ED}"/usr/share/gdb/python/gdb
fi
}