summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gdb/gdb-9.1.ebuild')
-rw-r--r--sys-devel/gdb/gdb-9.1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sys-devel/gdb/gdb-9.1.ebuild b/sys-devel/gdb/gdb-9.1.ebuild
index 85e667269711..9361fca6fb0c 100644
--- a/sys-devel/gdb/gdb-9.1.ebuild
+++ b/sys-devel/gdb/gdb-9.1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python{3_6,3_7} )
-inherit eutils flag-o-matic python-single-r1
+inherit eutils flag-o-matic python-single-r1 toolchain-funcs
export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
@@ -183,6 +183,9 @@ src_configure() {
myconf+=( --disable-largefile )
fi
+ # source-highlight is detected with pkg-config: bug #716558
+ export ac_cv_path_pkg_config_prog_path="$(tc-getPKG_CONFIG)"
+
mkdir "${GDB_BUILD_DIR}" || die
pushd "${GDB_BUILD_DIR}" || die
ECONF_SOURCE=${S}