summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/icecream/icecream-1.0.0-r1.ebuild')
-rw-r--r--sys-devel/icecream/icecream-1.0.0-r1.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/sys-devel/icecream/icecream-1.0.0-r1.ebuild b/sys-devel/icecream/icecream-1.0.0-r1.ebuild
deleted file mode 100644
index ab7e41ef9c26..000000000000
--- a/sys-devel/icecream/icecream-1.0.0-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-MY_P="${P/icecream/icecc}"
-
-inherit base eutils ltprune user
-
-DESCRIPTION="Distributed compiling of C(++) code across several machines; based on distcc"
-HOMEPAGE="https://github.com/icecc/icecream"
-SRC_URI="ftp://ftp.suse.com/pub/projects/${PN}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
-IUSE=""
-
-RDEPEND="
- sys-libs/libcap-ng
-"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}/${P}-libcap-ng.patch"
-)
-
-pkg_setup() {
- enewgroup icecream
- enewuser icecream -1 -1 /var/cache/icecream icecream
-}
-
-src_configure() {
- econf \
- --enable-shared --disable-static \
- --enable-clang-wrappers \
- --enable-clang-rewrite-includes
-}
-
-src_install() {
- default
- prune_libtool_files --all
-
- newconfd suse/sysconfig.icecream icecream
- newinitd "${FILESDIR}"/icecream-r2 icecream
-
- insinto /etc/logrotate.d
- newins suse/logrotate icecream
-}