summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/lld/lld-19.0.0.9999.ebuild')
-rw-r--r--sys-devel/lld/lld-19.0.0.9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/sys-devel/lld/lld-19.0.0.9999.ebuild b/sys-devel/lld/lld-19.0.0.9999.ebuild
index e72385c1bdb1..db957ad1ab9a 100644
--- a/sys-devel/lld/lld-19.0.0.9999.ebuild
+++ b/sys-devel/lld/lld-19.0.0.9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake flag-o-matic llvm llvm.org python-any-r1 toolchain-funcs
+inherit cmake flag-o-matic llvm.org llvm-utils python-any-r1 toolchain-funcs
DESCRIPTION="The LLVM linker (link editor)"
HOMEPAGE="https://llvm.org/"
@@ -41,7 +41,6 @@ python_check_deps() {
}
pkg_setup() {
- LLVM_MAX_SLOT=${LLVM_MAJOR} llvm_pkg_setup
use test && python-any-r1_pkg_setup
}
@@ -57,6 +56,8 @@ src_unpack() {
}
src_configure() {
+ llvm_prepend_path "${LLVM_MAJOR}"
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"