summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/llvm/llvm-3.7.0-r2.ebuild')
-rw-r--r--sys-devel/llvm/llvm-3.7.0-r2.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-devel/llvm/llvm-3.7.0-r2.ebuild b/sys-devel/llvm/llvm-3.7.0-r2.ebuild
index 8856b56b9cbe..bc2726d7f97a 100644
--- a/sys-devel/llvm/llvm-3.7.0-r2.ebuild
+++ b/sys-devel/llvm/llvm-3.7.0-r2.ebuild
@@ -72,7 +72,7 @@ PDEPEND="clang? ( =sys-devel/clang-${PV}-r100 )"
# pypy gives me around 1700 unresolved tests due to open file limit
# being exceeded. probably GC does not close them fast enough.
REQUIRED_USE="${PYTHON_REQUIRED_USE}
- lldb? ( clang )
+ lldb? ( clang xml )
test? ( || ( $(python_gen_useflags 'python*') ) )"
S=${WORKDIR}/${P/_}.src
@@ -262,6 +262,12 @@ multilib_src_configure() {
-DHAVE_HISTEDIT_H=$(usex libedit)
)
+ if use clang; then
+ mycmakeargs+=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_LibXml2=$(usex !xml)
+ )
+ fi
+
if use lldb; then
mycmakeargs+=(
-DLLDB_DISABLE_LIBEDIT=$(usex !libedit)