summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/llvm/llvm-9999.ebuild')
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild22
1 files changed, 4 insertions, 18 deletions
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 7150aa89d74e..a41369233a8a 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -178,10 +178,7 @@ src_prepare() {
# Automatically select active system GCC's libraries, bugs #406163 and #417913
epatch "${FILESDIR}"/clang-3.5-gentoo-runtime-gcc-detection-v3.patch
- epatch "${FILESDIR}"/clang-3.6-gentoo-install.patch
-
- sed -i -e "s^@EPREFIX@^${EPREFIX}^" \
- tools/clang/tools/scan-build/scan-build || die
+ epatch "${FILESDIR}"/clang-3.8-gentoo-install.patch
# Install clang runtime into /usr/lib/clang
# https://llvm.org/bugs/show_bug.cgi?id=23792
@@ -464,22 +461,9 @@ multilib_src_install_all() {
if use clang; then
pushd tools/clang >/dev/null || die
- if use static-analyzer ; then
- pushd tools/scan-build >/dev/null || die
-
- dobin ccc-analyzer scan-build
- dosym ccc-analyzer /usr/bin/c++-analyzer
- doman scan-build.1
-
- insinto /usr/share/llvm
- doins scanview.css sorttable.js
-
- popd >/dev/null || die
- fi
-
python_inst() {
if use static-analyzer ; then
- pushd tools/scan-view >/dev/null || die
+ pushd tools/scan-view/bin >/dev/null || die
python_doscript scan-view
@@ -488,6 +472,8 @@ multilib_src_install_all() {
python_domodule *.py Resources
popd >/dev/null || die
+
+ # TODO: remove files installed in /usr/share
fi
if use python ; then