summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/llvm-3.7.1-r3.ebuild (renamed from sys-devel/llvm/llvm-3.7.1-r2.ebuild)7
-rw-r--r--sys-devel/llvm/llvm-3.8.0-r3.ebuild (renamed from sys-devel/llvm/llvm-3.8.0-r2.ebuild)7
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild6
3 files changed, 14 insertions, 6 deletions
diff --git a/sys-devel/llvm/llvm-3.7.1-r2.ebuild b/sys-devel/llvm/llvm-3.7.1-r3.ebuild
index 65f2fc74005c..a76fae770b75 100644
--- a/sys-devel/llvm/llvm-3.7.1-r2.ebuild
+++ b/sys-devel/llvm/llvm-3.7.1-r3.ebuild
@@ -136,6 +136,8 @@ src_unpack() {
}
src_prepare() {
+ python_setup
+
# Make ocaml warnings non-fatal, bug #537308
sed -e "/RUN/s/-warn-error A//" -i test/Bindings/OCaml/*ml || die
# Fix libdir for ocaml bindings install, bug #559134
@@ -204,6 +206,9 @@ src_prepare() {
# https://llvm.org/bugs/show_bug.cgi?id=23793
eapply "${FILESDIR}"/cmake/clang-0002-cmake-Make-CLANG_LIBDIR_SUFFIX-overridable.patch
+ # Fix git-clang-format shebang, bug #562688
+ python_fix_shebang tools/clang/tools/clang-format/git-clang-format
+
pushd projects/compiler-rt >/dev/null || die
# Fix msan with newer kernels, compiler-rt part, #569894
@@ -236,8 +241,6 @@ src_prepare() {
# User patches
eapply_user
- python_setup
-
# Native libdir is used to hold LLVMgold.so
NATIVE_LIBDIR=$(get_libdir)
}
diff --git a/sys-devel/llvm/llvm-3.8.0-r2.ebuild b/sys-devel/llvm/llvm-3.8.0-r3.ebuild
index 2a1183025543..bc84e8fc5637 100644
--- a/sys-devel/llvm/llvm-3.8.0-r2.ebuild
+++ b/sys-devel/llvm/llvm-3.8.0-r3.ebuild
@@ -137,6 +137,8 @@ src_unpack() {
}
src_prepare() {
+ python_setup
+
# Make ocaml warnings non-fatal, bug #537308
sed -e "/RUN/s/-warn-error A//" -i test/Bindings/OCaml/*ml || die
# Fix libdir for ocaml bindings install, bug #559134
@@ -201,6 +203,9 @@ src_prepare() {
# https://llvm.org/bugs/show_bug.cgi?id=23793
eapply "${FILESDIR}"/cmake/clang-0002-cmake-Make-CLANG_LIBDIR_SUFFIX-overridable.patch
+ # Fix git-clang-format shebang, bug #562688
+ python_fix_shebang tools/clang/tools/clang-format/git-clang-format
+
# Fix 'stdarg.h' file not found on Gentoo/FreeBSD, bug #578064
# https://llvm.org/bugs/show_bug.cgi?id=26651
eapply "${FILESDIR}"/clang-3.8-compiler-rt-fbsd.patch
@@ -227,8 +232,6 @@ src_prepare() {
# User patches
eapply_user
- python_setup
-
# Native libdir is used to hold LLVMgold.so
NATIVE_LIBDIR=$(get_libdir)
}
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 8d290ba2353f..148ed8a4286b 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -107,6 +107,8 @@ pkg_pretend() {
pkg_setup() {
pkg_pretend
+
+ python-single-r1_pkg_setup
}
src_unpack() {
@@ -140,6 +142,8 @@ src_unpack() {
}
src_prepare() {
+ python_setup
+
# Make ocaml warnings non-fatal, bug #537308
sed -e "/RUN/s/-warn-error A//" -i test/Bindings/OCaml/*ml || die
# Fix libdir for ocaml bindings install, bug #559134
@@ -203,8 +207,6 @@ src_prepare() {
# User patches
eapply_user
- python_setup
-
# Native libdir is used to hold LLVMgold.so
NATIVE_LIBDIR=$(get_libdir)
}