summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/llvmgold/llvmgold-19.ebuild')
-rw-r--r--sys-devel/llvmgold/llvmgold-19.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/sys-devel/llvmgold/llvmgold-19.ebuild b/sys-devel/llvmgold/llvmgold-19.ebuild
new file mode 100644
index 000000000000..cc4a41d311fc
--- /dev/null
+++ b/sys-devel/llvmgold/llvmgold-19.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="LLVMgold plugin symlink for autoloading"
+HOMEPAGE="https://llvm.org/"
+S=${WORKDIR}
+
+LICENSE="public-domain"
+SLOT="0"
+
+RDEPEND="
+ sys-devel/llvm:${PV}[binutils-plugin]
+ !sys-devel/llvm:0
+"
+
+src_install() {
+ dodir "/usr/${CHOST}/binutils-bin/lib/bfd-plugins"
+ dosym "../../../../lib/llvm/${PV}/$(get_libdir)/LLVMgold.so" \
+ "/usr/${CHOST}/binutils-bin/lib/bfd-plugins/LLVMgold.so"
+}