summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/mold/files/mold-1.3.0-openssl-pkgconfig.patch')
-rw-r--r--sys-devel/mold/files/mold-1.3.0-openssl-pkgconfig.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-devel/mold/files/mold-1.3.0-openssl-pkgconfig.patch b/sys-devel/mold/files/mold-1.3.0-openssl-pkgconfig.patch
new file mode 100644
index 000000000000..d2ed0af47b41
--- /dev/null
+++ b/sys-devel/mold/files/mold-1.3.0-openssl-pkgconfig.patch
@@ -0,0 +1,28 @@
+From a4fde946f49cddf4f7c1eceb3b86ca38375cec1d Mon Sep 17 00:00:00 2001
+From: Matthew Smith <matt@offtopica.uk>
+Date: Sun, 26 Jun 2022 13:44:36 +0100
+Subject: [PATCH] Revert "Do not use pkg-config"
+
+This reverts commit 4ef90d4316bbba3a4b8902e38bf5f68171cc6ab7.
+--- a/Makefile
++++ b/Makefile
+@@ -18,6 +18,9 @@ ifeq ($(origin CXX), default)
+ CXX = c++
+ endif
+
++# Allow overriding pkg-config binary
++PKG_CONFIG = pkg-config
++
+ # If you want to keep symbols in the installed binary, run make with
+ # `STRIP=true` to run /bin/true instead of the strip command.
+ STRIP = strip
+@@ -100,7 +103,8 @@ ifeq ($(OS), Darwin)
+ endif
+
+ ifeq ($(NEEDS_LIBCRYPTO), 1)
+- MOLD_LDFLAGS += -lcrypto
++ MOLD_CXXFLAGS += $(shell $(PKG_CONFIG) --cflags-only-I openssl)
++ MOLD_LDFLAGS += $(shell $(PKG_CONFIG) --libs-only-L openssl) -lcrypto
+ endif
+
+ # '-latomic' flag is needed building on riscv64 system.