summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/slibtool/slibtool-9999.ebuild')
-rw-r--r--sys-devel/slibtool/slibtool-9999.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/sys-devel/slibtool/slibtool-9999.ebuild b/sys-devel/slibtool/slibtool-9999.ebuild
new file mode 100644
index 000000000000..b0b74aa5e382
--- /dev/null
+++ b/sys-devel/slibtool/slibtool-9999.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A skinny libtool implementation, written in C"
+HOMEPAGE="https://git.midipix.org/cgit.cgi/slibtool"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.midipix.org/slibtool"
+else
+ SRC_URI="https://git.midipix.org/cgit.cgi/${PN}/snapshot/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm"
+fi
+LICENSE="MIT"
+SLOT="0"
+
+src_configure() {
+ # custom configure script (not generated by autoconf)
+ ./configure --host=${CHOST} --prefix="${EPREFIX}"/usr || die
+}